Bug 2708 - Checked out items saying available
Summary: Checked out items saying available
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: PC All
: P3 major (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-22 02:48 UTC by Nicole C. Engard
Modified: 2014-12-07 20:02 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
some avail - some not (210.85 KB, image/png)
2008-10-22 02:49 UTC, Chris Cormack
Details
another example (11.46 KB, image/png)
2008-10-22 02:49 UTC, Chris Cormack
Details
results show the right info (30.95 KB, image/png)
2009-02-13 08:12 UTC, Chris Cormack
Details
detail page shows diff details than results (69.64 KB, image/png)
2009-02-13 08:12 UTC, Chris Cormack
Details
staff interface (149.42 KB, image/png)
2011-05-18 00:59 UTC, infotech.sbc
Details
OPAC (170.17 KB, image/png)
2011-05-18 01:00 UTC, infotech.sbc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 00:54:57 UTC


---- Reported by nengard@gmail.com 2008-10-22 02:48:45 ----

In the attached screenshots you'll see that some items which are very obviously checked out are also saying that they're available.  It's not every item though - just sometimes. I'm including screenshots from two different OPACs.



---- Additional Comments From nengard@gmail.com 2008-10-22 02:49:07 ----

Created an attachment
some avail - some not





---- Additional Comments From nengard@gmail.com 2008-10-22 02:49:25 ----

Created an attachment
another example





---- Additional Comments From nengard@gmail.com 2008-10-22 02:55:31 ----

Some examples from Joe:


mysql> select biblio.title, biblio.author, items.* from items LEFT JOIN biblio on (biblio.biblionumber=items.biblionumber) where barcode="55500000000381";
+---------------------------+-------------------+------------+--------------+------------------+----------------+-----------------+--------------+------------+-------+------------------+----------------------+------------------+--------------+-------+------------+---------+----------+----------+----------------+--------+----------+----------+------------+-----------+---------------+---------+---------------------+----------+--------+-----------+---------+-------+-----------+------+----------+--------------------+-----------+------------+
| title                     | author            | itemnumber | biblionumber | biblioitemnumber | barcode        | dateaccessioned | booksellerid | homebranch | price | replacementprice | replacementpricedate | datelastborrowed | datelastseen | stack | notforloan | damaged | itemlost | wthdrawn | itemcallnumber | issues | renewals | reserves | restricted | itemnotes | holdingbranch | paidfor | timestamp           | location | onloan | cn_source | cn_sort | ccode | materials | uri  | itype    | more_subfields_xml | enumchron | copynumber |
+---------------------------+-------------------+------------+--------------+------------------+----------------+-----------------+--------------+------------+-------+------------------+----------------------+------------------+--------------+-------+------------+---------+----------+----------+----------------+--------+----------+----------+------------+-----------+---------------+---------+---------------------+----------+--------+-----------+---------+-------+-----------+------+----------+--------------------+-----------+------------+
| Organizational behavior : | Nelson, Debra L., |      25412 |        19163 |            19163 | 55500000000381 | 2007-06-10      | NULL         | TXT        |  NULL |             NULL | 2008-06-10           | NULL             | 2008-09-02   |  NULL |          0 |       0 |        0 |        0 | BUS 350        |   NULL |     NULL |     NULL |       NULL | NULL      | NULL          | NULL    | 2008-09-02 09:20:25 | NULL     | NULL   | NULL      | BUS_350 | TXT   | NULL      | NULL | TEXTBOOK | NULL               | NULL      | NULL       |
+---------------------------+-------------------+------------+--------------+------------------+----------------+-----------------+--------------+------------+-------+------------------+----------------------+------------------+--------------+-------+------------+---------+----------+----------+----------------+--------+----------+----------+------------+-----------+---------------+---------+---------------------+----------+--------+-----------+---------+-------+-----------+------+----------+--------------------+-----------+------------+
1 row in set (0.00 sec)


mysql> select ccode,count(*) from items WHERE biblionumber=19163 GROUP BY ccode ;
+-------+----------+
| ccode | count(*) |
+-------+----------+
| RES   |        1 |
| T     |        2 |
| TXT   |       51 |
+-------+----------+
3 rows in set (0.00 sec)

mysql> select homebranch,count(*) from items WHERE biblionumber=19163 GROUP BY homebranch ;
+------------+----------+
| homebranch | count(*) |
+------------+----------+
| LCC        |        1 |
| TXT        |       53 |
+------------+----------+
2 rows in set (0.00 sec)

mysql> select location,count(*) from items WHERE biblionumber=19163 GROUP BY location ;
+----------+----------+
| location | count(*) |
+----------+----------+
| NULL     |       54 |
+----------+----------+
1 row in set (0.00 sec)

mysql> select itype,count(*) from items WHERE biblionumber=19163 GROUP BY itype ;
+----------+----------+
| itype    | count(*) |
+----------+----------+
| R        |        1 |
| RH2      |        1 |
| TEXTBOOK |       52 |
+----------+----------+
3 rows in set (0.00 sec)




---- Additional Comments From nengard@gmail.com 2008-11-10 10:13:21 ----

I have support tickets regarding this issue.  Any ideas?



---- Additional Comments From jmf@liblime.com 2008-11-27 11:26:27 ----

There is not enough information here for me to determine:

1. which specific pages are displaying Available incorrectly (paths please)

2. what the purpose of the SQL in this report is ... what is that showing exactly?



---- Additional Comments From joe.atzberger@liblime.com 2008-11-27 11:45:28 ----

The attachments are clearly the staff search results and details page.



---- Additional Comments From kyle.m.hall@gmail.com 2008-12-05 09:35:30 ----

I've submitted a patch that ports my dev_week reserves enhancements to Koha 3.



---- Additional Comments From nengard@gmail.com 2009-02-13 08:12:09 ----

Created an attachment
results show the right info





---- Additional Comments From nengard@gmail.com 2009-02-13 08:12:40 ----

Created an attachment
detail page shows diff details than results





---- Additional Comments From joe.atzberger@liblime.com 2009-02-13 10:47:11 ----

The SQL Nicole included is only peripherally related.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 00:54 UTC  ---

This bug was previously known as _bug_ 2708 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2708
Imported an attachment (id=808)
Imported an attachment (id=809)
Imported an attachment (id=810)
Imported an attachment (id=811)

Actual time not defined. Setting to 0.0
CC member bchurch@ptfs.com does not have an account here
CC member joe.atzberger@liblime.com does not have an account here
The original submitter of attachment 808 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 809 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 810 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 811 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Koustubha Kale 2010-07-01 07:16:32 UTC
I have this exact problem in 3.00.05.003 in the staff search results and details page.
Comment 2 infotech.sbc 2011-05-18 00:57:00 UTC
I'm experiencing this same bug in koha 3.04

An item that was already checked out is available in the search result in the OPAC.
Comment 3 infotech.sbc 2011-05-18 00:59:28 UTC
Created attachment 4162 [details]
staff interface
Comment 4 infotech.sbc 2011-05-18 01:00:33 UTC
Created attachment 4163 [details]
OPAC
Comment 5 Liz Rea 2012-05-02 14:42:29 UTC
I have not observed this in the wild for some time - and if it *does* happen, it is often caused by an out-of-sync index, which forcing an update to the index usually fixes the issue.

Closing.