Bug 27099 - Stage for import button not showing up
Summary: Stage for import button not showing up
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic record staging/import (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-25 21:37 UTC by Eric Bégin
Modified: 2021-06-14 21:35 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.01,20.05.07,19.11.14


Attachments
Bug 27099: Stage for import button not showing up (1.76 KB, patch)
2020-12-14 13:03 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27099: Stage for import button not showing up (1.81 KB, patch)
2020-12-16 00:14 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 27099: Stage for import button not showing up (1.87 KB, patch)
2020-12-21 16:53 UTC, Nick Clemens
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Bégin 2020-11-25 21:37:58 UTC
Some of our clients report that the 'Stage for import' button disappeared in the Stage MARC records page.

This problem seams to be related to Chrome 87.

The button is still there, but hidden by the language bar at the bottom of the page.

A temporary workaround is to add a margin to the <main> element in IntranetUserCSS

In our case, we added

main {
    margin-bottom: 50px;
}

The problem is also present on 20.05

No tested yet on master.
Comment 1 Jonathan Druart 2020-12-01 10:30:07 UTC
It's working for me on master on both Firefox 68.12.0esr and Chromium 83.0.4103.116
Comment 2 George Williams (NEKLS) 2020-12-11 21:23:30 UTC
We are having the same problem on Koha 19.05 and Chrome 87 for these pages:

tools_batchMod-edit
tools_stage-marc-import
admin_preferences

For admin_preferences the "Save all . . . preferences" buttons at the bottom of the page are covered by the language selector whenever the length of .col-sm-10.col-sm-push-2 is greater than the length of .col-sm-2.col-sm-pull-10

As far as I can tell, it's only happening on Chrome 87.  I can't recreate the same problem on Firefox or older versions of Chrome.
Comment 3 Jonathan Druart 2020-12-14 10:24:01 UTC
Confirmed on master with Chrome 87.
Comment 4 Owen Leonard 2020-12-14 13:03:43 UTC Comment hidden (obsolete)
Comment 5 Lucas Gass 2020-12-16 00:14:16 UTC Comment hidden (obsolete)
Comment 6 Lucas Gass 2020-12-16 00:16:10 UTC
Thanks for this one, it has been troubling me lately as I could not recreate until I upgraded to Chrome 87.
Comment 7 Nick Clemens 2020-12-21 16:53:46 UTC
Created attachment 114571 [details] [review]
Bug 27099: Stage for import button not showing up

In the latest version of Chrome, pages where the Humansmg library is
included have a problem where the language footer obscures the bottom of
the page.

The problem traces back to some CSS in the Humanmsg library's CSS file:

html, body {
    height: 100%; /* Damn you IE! */
}

Removing the line doesn't have any ill effects that I can see in Chrome
or Firefox, and it fixes the problem in Chrome. IE can be damned.

To test you must have one or more translations enabled in the staff
interface.

- Apply the patch and clear your browser cache if necessary.
- View pages in the staff interface which use the Humansmg library,
  e.g.:
  - Administration -> System preferences. Choose a category of
    preferences which will be numerous enough to require scrolling to
    reach the bottom of the page.
  - Tools -> Stage MARC records for import. Upload a file to display the
    form for staging the import.
  - Cataloging -> Advanced MARC editor

On each page the language footer should not obscure the bottom of the
page.

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>

Signed-off-by: Nick Clemens <nick@bywatersolutions.com>
Comment 8 Jonathan Druart 2020-12-26 17:15:15 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 9 Fridolin Somers 2020-12-30 14:46:03 UTC
Pushed to 20.11.x for 20.11.01
Comment 10 Andrew Fuerste-Henry 2021-01-04 22:24:21 UTC
Pushed to 20.05.x for 20.05.07
Comment 11 Victor Grousset/tuxayo 2021-01-10 16:33:23 UTC
Backported to 19.11.x branch for 19.11.14