Bug 27147 - Self registration broken if PatronSelfRegistrationBorrowerUnwantedField contains "categorycode"
Summary: Self registration broken if PatronSelfRegistrationBorrowerUnwantedField conta...
Status: RESOLVED DUPLICATE of bug 27148
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low critical (vote)
Assignee: Agustín Moyano
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-03 14:26 UTC by Jonathan Druart
Modified: 2020-12-03 14:40 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2020-12-03 14:26:50 UTC
If the category dropdown list is not appearing on the self registration form, then the form submision fails.

First the form displays "Password must contain at least undefined characters", then a 500 "[You must provide a patron's category to validate password's strength and length] at /usr/share/perl5/Exception/Class/Base.pm line 88"
Comment 1 Jonathan Druart 2020-12-03 14:32:10 UTC

*** This bug has been marked as a duplicate of bug 27148 ***