Bug 27473 - Improve link text in the installer
Summary: Improve link text in the installer
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Eden
QA Contact: Victor Grousset/tuxayo
URL:
Keywords: Academy
Depends on:
Blocks: 26722
  Show dependency treegraph
 
Reported: 2021-01-20 01:08 UTC by Aleisha Amohia
Modified: 2021-06-14 21:35 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Text to go in the release notes:
Version(s) released in:
21.05.00


Attachments
Bug 27473: Imrpoved link text in installer (1.40 KB, patch)
2021-01-20 02:16 UTC, Eden
Details | Diff | Splinter Review
Bug 27473: Imrpoved link text in installer (1.38 KB, patch)
2021-01-21 22:25 UTC, Eden
Details | Diff | Splinter Review
Bug 27473: Improved link text in installer (1.33 KB, patch)
2021-01-21 23:10 UTC, Eden
Details | Diff | Splinter Review
Bug 27473: Improved link text in installer (1.39 KB, patch)
2021-01-21 23:22 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27473: Improved link text in installer (1.39 KB, patch)
2021-02-07 11:18 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27473: (follow-up) Change wording of the button (1.20 KB, patch)
2021-02-07 11:18 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 27473: Improved link text in installer (1.44 KB, patch)
2021-02-26 20:49 UTC, Victor Grousset/tuxayo
Details | Diff | Splinter Review
Bug 27473: (follow-up) Change wording of the button (1.25 KB, patch)
2021-02-26 20:49 UTC, Victor Grousset/tuxayo
Details | Diff | Splinter Review
Bug 27473: (follow-up) Remove the redirect message (1.41 KB, patch)
2021-03-01 13:11 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27473: Remove the redirect after 10sec (926 bytes, patch)
2021-03-01 13:16 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Aleisha Amohia 2021-01-20 01:08:44 UTC
koha-tmpl/intranet-tmpl/prog/en/modules/installer/step3.tt:                    <p>This page will redirect in 10 seconds. <a href="/cgi-bin/koha/installer/onboarding.pl">If not, click here to start onboarding process.</a></p>

"Here" should not be used as a link text as it doesn't contain any helpful information for people scanning the page for information and also is a problem for blind users using screen readers jumping from link to link on a page.

To reproduce:
1. in your terminal, run reset_all
this will drop and recreate your database so that you can go through the installer
2. go through the steps of the installer
3. after importing sample data you'll notice the 'click here' message
Comment 1 Eden 2021-01-20 02:16:26 UTC
Created attachment 115400 [details] [review]
Bug 27473: Imrpoved link text in installer

Test Plan
1. run reset_all to run koha installer
2. Check that after importing sample data step that the link does not
include click and is easily understood
Comment 2 Owen Leonard 2021-01-21 19:10:01 UTC
I think the use of "this link" in the sentence is not better than "click here." I think something like simply "Continue to the next stage" would work.
Comment 3 Eden 2021-01-21 22:25:58 UTC
Created attachment 115627 [details] [review]
Bug 27473: Imrpoved link text in installer

Test Plan
1. run reset_all to run koha installer
2. Check that after importing sample data step that link says 'Continue
to the next stage'
Comment 4 Katrin Fischer 2021-01-21 22:59:06 UTC
Now the link is really long and still has the "link" - which I think we don't need to mention. The browser formatting and the screen readers will already transport that information.

What about: Jump to onboarding process
Comment 5 Eden 2021-01-21 23:10:59 UTC
Created attachment 115643 [details] [review]
Bug 27473: Improved link text in installer

Test Plan
1. run reset_all to run koha installer
2. Check that after importing sample data step that link says 'Continue
to the next stage'
Comment 6 Katrin Fischer 2021-01-21 23:22:32 UTC
Created attachment 115645 [details] [review]
Bug 27473: Improved link text in installer

Test Plan
1. run reset_all to run koha installer
2. Check that after importing sample data step that link says 'Continue
to the next stage'

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Martin Renvoize 2021-02-02 10:40:12 UTC
I'm not so sure about this change.. the two actions no longer seem related... it feels like you're now in a race against the reload to click a button you don't know where it goes...
Comment 8 Katrin Fischer 2021-02-07 11:16:22 UTC
I am not sure why we have this delayed redirect at all, but it's been done like this forever. We step through all other parts of the installer process using buttons... :) I am going to propose "Continue with the onboarding process".
Comment 9 Katrin Fischer 2021-02-07 11:18:12 UTC
Created attachment 116458 [details] [review]
Bug 27473: Improved link text in installer

Test Plan
1. run reset_all to run koha installer
2. Check that after importing sample data step that link says 'Continue
to the next stage'

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 10 Katrin Fischer 2021-02-07 11:18:16 UTC
Created attachment 116459 [details] [review]
Bug 27473: (follow-up) Change wording of the button
Comment 11 Victor Grousset/tuxayo 2021-02-26 20:49:05 UTC
Created attachment 117402 [details] [review]
Bug 27473: Improved link text in installer

Test Plan
1. run reset_all to run koha installer
2. Check that after importing sample data step that link says 'Continue
to the next stage'

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net>
Comment 12 Victor Grousset/tuxayo 2021-02-26 20:49:08 UTC
Created attachment 117403 [details] [review]
Bug 27473: (follow-up) Change wording of the button

Signed-off-by: Victor Grousset/tuxayo <victor@tuxayo.net>
Comment 13 Owen Leonard 2021-03-01 13:11:30 UTC
Created attachment 117447 [details] [review]
Bug 27473: (follow-up) Remove the redirect message

I don't think it's necessary to remove the redirect because I don't
think it does any harm, but why include a message about it? I think we
should treat this step like all the others and provide a button to take
the user to the next page.
Comment 14 Jonathan Druart 2021-03-01 13:16:53 UTC
Created attachment 117448 [details] [review]
Bug 27473: Remove the redirect after 10sec
Comment 15 Jonathan Druart 2021-03-01 13:17:43 UTC
Then going a bit further and removing the redirect. Katrin, Martin, would you agree?
Comment 16 Martin Renvoize 2021-03-01 14:04:03 UTC
Seems reasonable to me :)
Comment 17 Jonathan Druart 2021-03-04 08:51:52 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 18 Fridolin Somers 2021-03-04 12:26:08 UTC
Enhancement not pushed to 20.11.x