Bug 27633 - Display of 440$v doubled up in the OPAC
Summary: Display of 440$v doubled up in the OPAC
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
: 27702 (view as bug list)
Depends on: 15436
Blocks:
  Show dependency treegraph
 
Reported: 2021-02-05 07:20 UTC by Michael Hoffert
Modified: 2021-02-17 20:28 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
This fixes the display of 440$v (Series Statement/Added Entry-Title - Volume/sequential designation ($v)) in the OPAC. Before this fix $v is included in the title link and then displayed after the ;. With the fix $v is only displayed after the ; and is not duplicated in the title link.
Version(s) released in:
21.05.00,20.11.03


Attachments
Bug 27633: (bug 15436 follow-up) Fix duplicate of 440$v at the OPAC (1.48 KB, patch)
2021-02-05 14:44 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27633: (bug 15436 follow-up) Fix duplicate of 440$v at the OPAC (1.53 KB, patch)
2021-02-05 18:40 UTC, David Nind
Details | Diff | Splinter Review
Bug 27633: (bug 15436 follow-up) Fix duplicate of 440$v at the OPAC (1.58 KB, patch)
2021-02-06 21:27 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hoffert 2021-02-05 07:20:06 UTC
When a reference is specified in 440 $v, it is displayed twice in the OPAC and in the search list. Once in the linked title and additionally as a reference.

Example:
Series: Hannah Arendt Institute for Research on Totalitarianism: Reports and Studies Volume 69 ; Volume 69

This is displayed correctly within the administration interface:
Series: Hannah Arendt Institute for Research on Totalitarianism: Reports and Studies ; Volume 69

https://bibo.saw-leipzig.de/cgi-bin/koha/opac-detail.pl?biblionumber=162

Regards
Michael
Comment 1 Jonathan Druart 2021-02-05 14:44:36 UTC
Created attachment 116396 [details] [review]
Bug 27633: (bug 15436 follow-up) Fix duplicate of 440$v at the OPAC

Only display a in link, not v that is displayed later.

It has been fixed in different other places by
  commit 81f71d45fe4fee92596ea8d8edb57c602490e9b1
  Bug 15436: Use semicolon between series name and volume

but missed one occurrence.

Test plan:
Add a 440$a and $v and confirm that the display at the OPAC is now the
same as the staff interface.
Comment 2 Michael Hoffert 2021-02-05 14:53:18 UTC
Thank you very much for the quick help. :-D
Comment 3 Jonathan Druart 2021-02-05 15:32:17 UTC
You are welcome Michael! :)

Can you confirm it works as you expected?
Comment 4 Michael Hoffert 2021-02-05 15:44:32 UTC
Unfortunately, I do not have access to the server. But I will try to convince our IT of the necessity of the change.
Comment 5 David Nind 2021-02-05 18:40:39 UTC
Created attachment 116430 [details] [review]
Bug 27633: (bug 15436 follow-up) Fix duplicate of 440$v at the OPAC

Only display a in link, not v that is displayed later.

It has been fixed in different other places by
  commit 81f71d45fe4fee92596ea8d8edb57c602490e9b1
  Bug 15436: Use semicolon between series name and volume

but missed one occurrence.

Test plan:
Add a 440$a and $v and confirm that the display at the OPAC is now the
same as the staff interface.

Signed-off-by: David Nind <david@davidnind.com>
Comment 6 Katrin Fischer 2021-02-06 21:27:15 UTC
Created attachment 116444 [details] [review]
Bug 27633: (bug 15436 follow-up) Fix duplicate of 440$v at the OPAC

Only display a in link, not v that is displayed later.

It has been fixed in different other places by
  commit 81f71d45fe4fee92596ea8d8edb57c602490e9b1
  Bug 15436: Use semicolon between series name and volume

but missed one occurrence.

Test plan:
Add a 440$a and $v and confirm that the display at the OPAC is now the
same as the staff interface.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2021-02-06 21:28:42 UTC
Thx for the patch - and sorry for missing that one in the first place!
Comment 8 Jonathan Druart 2021-02-08 13:58:15 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 9 Fridolin Somers 2021-02-12 13:06:34 UTC
Pushed to 20.11.x for 20.11.03
Comment 10 Katrin Fischer 2021-02-15 07:22:14 UTC
*** Bug 27702 has been marked as a duplicate of this bug. ***
Comment 11 Andrew Fuerste-Henry 2021-02-17 20:28:04 UTC
missing dependency, not backported to 20.05.x