Bug 27671 - Missing include in orderreceive.tt
Summary: Missing include in orderreceive.tt
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Marcel de Rooy
URL:
Keywords: rel_20_11_candidate
Depends on: 23376
Blocks: 26693
  Show dependency treegraph
 
Reported: 2021-02-10 14:03 UTC by Tomás Cohen Arazi
Modified: 2021-02-22 21:31 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.05.00,20.11.03


Attachments
Bug 27671: Restore missing include in orderreceive.tt (844 bytes, patch)
2021-02-10 14:06 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 27671: Restore missing include in orderreceive.tt (893 bytes, patch)
2021-02-10 18:08 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 27671: Restore missing include in orderreceive.tt (1.05 KB, patch)
2021-02-11 08:17 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27671: Use Koha.Preference for UniqueItemFields (1.13 KB, patch)
2021-02-11 15:39 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 27671: Restore missing include in orderreceive.tt (1.15 KB, patch)
2021-02-12 07:28 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 27671: Use Koha.Preference for UniqueItemFields (1.22 KB, patch)
2021-02-12 07:28 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2021-02-10 14:03:26 UTC
Some checks require Koha.Preference, but the 'Koha' plugin is not being included. This doesn't fail because the call to Koha.Preference just returns false. But the code validating the data is not being called.
Comment 1 Tomás Cohen Arazi 2021-02-10 14:06:05 UTC
Created attachment 116669 [details] [review]
Bug 27671: Restore missing include in orderreceive.tt

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 2 Owen Leonard 2021-02-10 18:08:15 UTC
Created attachment 116686 [details] [review]
Bug 27671: Restore missing include in orderreceive.tt

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Jonathan Druart 2021-02-11 08:17:35 UTC
Created attachment 116693 [details] [review]
Bug 27671: Restore missing include in orderreceive.tt

Caused by
  commit 15e35f77fb29137a5421ff79a1186087508aa68f
  Bug 23376: Move AcqCreateItem logic to template

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 4 Nick Clemens 2021-02-11 11:28:45 UTC
This is definitely correct, but it doesn't solve the issue I see

To test:
1 - Set AcqCreateItem to 'receiving an order'
2 - Set  UniqueItemFields  to barcode|materials
3 - Add the words 'qwertytest' to materials field for existing item
4 - Attempt to receive an item, adding 'qwertytest' to the materials field

Both before and after the patch I was warned of duplicate information, no matter what values I had in the materials or barcode field
Comment 5 Jonathan Druart 2021-02-11 15:39:51 UTC
Created attachment 116770 [details] [review]
Bug 27671: Use Koha.Preference for UniqueItemFields
Comment 6 Marcel de Rooy 2021-02-12 07:28:13 UTC
Created attachment 116784 [details] [review]
Bug 27671: Restore missing include in orderreceive.tt

Caused by
  commit 15e35f77fb29137a5421ff79a1186087508aa68f
  Bug 23376: Move AcqCreateItem logic to template

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 7 Marcel de Rooy 2021-02-12 07:28:16 UTC
Created attachment 116785 [details] [review]
Bug 27671: Use Koha.Preference for UniqueItemFields

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 8 Jonathan Druart 2021-02-12 11:19:01 UTC
Pushed to master for 21.05, thanks to everybody involved!
Comment 9 Fridolin Somers 2021-02-19 14:45:36 UTC
Pushed to 20.11.x for 20.11.03
Comment 10 Andrew Fuerste-Henry 2021-02-22 21:31:56 UTC
Missing dependencies, not backported to 20.05