Bug 28060 - Point of sale debits should not automatically sort when edited
Summary: Point of sale debits should not automatically sort when edited
Status: RESOLVED DUPLICATE of bug 27776
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: 20.05
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-30 20:50 UTC by Esther Melander
Modified: 2021-04-02 15:24 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Esther Melander 2021-03-30 20:50:48 UTC
When editing debits in the point of sale, the debit costs automatically sort from lowest to highest cost amount. This can cause an error because the debit changes places on the screen. When training staff, I observed numerous errors because of the auto shifting of debits.

To repeat:
1. Add multiple debits to point of sale.
2. Click on the debit cost and change the cost.

The debit will automatically move up and down the list depending on the price.
If you are also editing the quantity, you now have to pay attention to the debit location to make sure you are editing the correct line item.

It would be better if the auto sorting was turned off by default. In addition it would be nice if there was a setting to choose whether the list is sorted by debit name or cost.
Comment 1 Katrin Fischer 2021-04-02 15:24:06 UTC
Hi Esther, I belive this has been fixed quite recently with bug 27776.

*** This bug has been marked as a duplicate of bug 27776 ***