Bug 28163 - Register entries doubled up if form is submitted first without a selected register
Summary: Register entries doubled up if form is submitted first without a selected reg...
Status: RESOLVED DUPLICATE of bug 30003
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-17 23:45 UTC by Katrin Fischer
Modified: 2022-02-10 11:13 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2021-04-17 23:45:26 UTC
Testing the patch on bug 28127 I noticed a lot of double ups in my registry details.

I think I know how to reproduce this:

- Add a debit type for sale with a default price
- Go to point of sale
- Make sure you have no register selected by default 
- Add your debit type to current sale
- Enter amount tendered
- Leave register blank and submit
- Set register
- Submit again
- Go to register details page use the link on the left

There are now 2 identical entries in the details table.
Comment 1 Martin Renvoize 2022-02-10 11:13:03 UTC

*** This bug has been marked as a duplicate of bug 30003 ***