Bug 28850 - Clarify wording on AllFinesNeedOverride system preference
Summary: Clarify wording on AllFinesNeedOverride system preference
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Andrew Fuerste-Henry
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-12 14:20 UTC by Andrew Fuerste-Henry
Modified: 2021-12-13 21:14 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
This clarifies the wording for the AllFinesNeedOverride system preference. If set to 'require', checkouts are blocked when using the web-based selfcheck and SIP.
Version(s) released in:
21.11.00


Attachments
Bug 28850: Reword AllFinesNeedOverride (1.55 KB, patch)
2021-08-13 16:22 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 28850: Reword AllFinesNeedOverride (1.59 KB, patch)
2021-08-16 20:34 UTC, David Nind
Details | Diff | Splinter Review
Bug 28850: Reword AllFinesNeedOverride (1.71 KB, patch)
2021-08-18 10:14 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 28850: (QA follow-up) Add "patrons with fines" for clarification (1.63 KB, patch)
2021-08-18 10:14 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2021-08-12 14:20:18 UTC
This syspref reads "[require/don't] staff to manually override all fines, even fines less than set in the noissuescharge system preference."

We should explicitly state that this entirely blocks self checkout via the Koha selfcheck (and possibly also via SIP, I need to test that). It's vaguely implied as-is, since by definition there's no staff member present at the selfcheck to perform that override, but an explicit statement would be much clearer.

I'm filing a separate bug to suggest an enhancement to split this into two system preferences.
Comment 1 Andrew Fuerste-Henry 2021-08-13 16:22:31 UTC
Created attachment 123831 [details] [review]
Bug 28850: Reword AllFinesNeedOverride

To test:
Apply patch, look up AllFinesNeedOverride, confirm it now says that checkouts will be blocked via the web-based selfcheck and SIP.
Comment 2 David Nind 2021-08-16 20:34:09 UTC
Created attachment 123860 [details] [review]
Bug 28850: Reword AllFinesNeedOverride

To test:
Apply patch, look up AllFinesNeedOverride, confirm it now says that checkouts will be blocked via the web-based selfcheck and SIP.

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 Katrin Fischer 2021-08-18 10:14:49 UTC
Created attachment 123934 [details] [review]
Bug 28850: Reword AllFinesNeedOverride

To test:
Apply patch, look up AllFinesNeedOverride, confirm it now says that checkouts will be blocked via the web-based selfcheck and SIP.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 4 Katrin Fischer 2021-08-18 10:14:53 UTC
Created attachment 123935 [details] [review]
Bug 28850: (QA follow-up) Add "patrons with fines" for clarification

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Katrin Fischer 2021-08-18 10:15:28 UTC
I can confirm from our experience that this also blocks checkouts via SIP2.
Comment 6 Jonathan Druart 2021-08-18 13:36:51 UTC
Pushed to master for 21.11, thanks to everybody involved!