Bug 29112 - Module navigation sidebars in staff now show bullet points
Summary: Module navigation sidebars in staff now show bullet points
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Owen Leonard
QA Contact: Joonas Kylmälä
URL:
Keywords:
Depends on: 27873
Blocks:
  Show dependency treegraph
 
Reported: 2021-09-26 10:59 UTC by Katrin Fischer
Modified: 2021-10-22 13:55 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:
21.11.00


Attachments
Bug 29112: Module navigation sidebars in staff now show bullet points (3.19 KB, patch)
2021-10-05 16:29 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 29112: Module navigation sidebars in staff now show bullet points (3.24 KB, patch)
2021-10-05 20:54 UTC, David Nind
Details | Diff | Splinter Review
Bug 29112: Module navigation sidebars in staff now show bullet points (3.38 KB, patch)
2021-10-10 10:23 UTC, Joonas Kylmälä
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2021-09-26 10:59:05 UTC
Not sure if this was an intentional change after all, but I noticed that on master the navigation sidebars (tools or administration for examples) now show bullet points before each link.
Comment 1 Katrin Fischer 2021-09-26 11:00:50 UTC
In earlier versions instead of the standard bullet point a custom image with a small arrow was used.
Comment 2 Katrin Fischer 2021-09-26 11:02:12 UTC
The image link appears now to be broken, but it's still in the code - so I guess this was not inentional after all.
Comment 3 Owen Leonard 2021-10-05 16:29:54 UTC
Created attachment 125746 [details] [review]
Bug 29112: Module navigation sidebars in staff now show bullet points

Bug 27873 removed an image file which was still being referenced in the
staff interface CSS, intended to replace the default bullet point in
sidebar menus like Administration and Tools pages have.

This patch creates a new variable in the SCSS "mixins" file so that the
SVG image file created by Bug 27873 can be reused, and corrects the CSS
for the affected menus.

To test, apply the patch and rebuild the staff interface CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Go to Tools -> Patron lists
  - The sidebar menu should be styled with little arrows instead of
    the default HTML bullets.
- Check the same on an Administration page, e.g. Administration ->
  Libraries.
- Check that there hasn't been a regression on the checkout and patron
  detail views:
  - Check out to a patron who has one or more messages on their account,
    e.g. overdues, return claims, holds waiting, notes, messages, etc.
  - The display of these list items should be the same: An arrow bullet
    point instead of the default.
Comment 4 David Nind 2021-10-05 20:54:28 UTC
Created attachment 125751 [details] [review]
Bug 29112: Module navigation sidebars in staff now show bullet points

Bug 27873 removed an image file which was still being referenced in the
staff interface CSS, intended to replace the default bullet point in
sidebar menus like Administration and Tools pages have.

This patch creates a new variable in the SCSS "mixins" file so that the
SVG image file created by Bug 27873 can be reused, and corrects the CSS
for the affected menus.

To test, apply the patch and rebuild the staff interface CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Go to Tools -> Patron lists
  - The sidebar menu should be styled with little arrows instead of
    the default HTML bullets.
- Check the same on an Administration page, e.g. Administration ->
  Libraries.
- Check that there hasn't been a regression on the checkout and patron
  detail views:
  - Check out to a patron who has one or more messages on their account,
    e.g. overdues, return claims, holds waiting, notes, messages, etc.
  - The display of these list items should be the same: An arrow bullet
    point instead of the default.

Signed-off-by: David Nind <david@davidnind.com>
Comment 5 Joonas Kylmälä 2021-10-10 10:23:19 UTC
Created attachment 126013 [details] [review]
Bug 29112: Module navigation sidebars in staff now show bullet points

Bug 27873 removed an image file which was still being referenced in the
staff interface CSS, intended to replace the default bullet point in
sidebar menus like Administration and Tools pages have.

This patch creates a new variable in the SCSS "mixins" file so that the
SVG image file created by Bug 27873 can be reused, and corrects the CSS
for the affected menus.

To test, apply the patch and rebuild the staff interface CSS
(https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client).

- Go to Tools -> Patron lists
  - The sidebar menu should be styled with little arrows instead of
    the default HTML bullets.
- Check the same on an Administration page, e.g. Administration ->
  Libraries.
- Check that there hasn't been a regression on the checkout and patron
  detail views:
  - Check out to a patron who has one or more messages on their account,
    e.g. overdues, return claims, holds waiting, notes, messages, etc.
  - The display of these list items should be the same: An arrow bullet
    point instead of the default.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Joonas Kylmälä <joonas.kylmala@iki.fi>
Comment 6 Joonas Kylmälä 2021-10-10 10:26:58 UTC
Fixes the problem, passing QA but noting down that those global variables could be moved in the future to _vars.scss now that we have such a file. Not blocking this because of that because there was pre-existing global variables already in the _mixins.scss file.

Also, please describe in the commit what the change does and not what problem it solves, at least not in the title. Makes easier to verify intended changes, otherwise I have to guess based on the problem.
Comment 7 Jonathan Druart 2021-10-12 09:18:54 UTC
Pushed to master for 21.11, thanks to everybody involved!