Bug 29309 - 'Pay all fines' should be 'Pay all charges'
Summary: 'Pay all fines' should be 'Pay all charges'
Status: Pushed to stable
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Testopia
URL:
Keywords: Manual
Depends on:
Blocks:
 
Reported: 2021-10-22 15:40 UTC by Tomás Cohen Arazi
Modified: 2021-11-10 23:39 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: String patch
Text to go in the release notes:
Version(s) released in:
21.11.00,21.05.05


Attachments
Bug 29309: Make 'Pay all fines' be 'Pay all charges' (1.59 KB, patch)
2021-10-22 22:01 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 29309: Make 'Pay all fines' be 'Pay all charges' (1.64 KB, patch)
2021-10-23 20:07 UTC, David Nind
Details | Diff | Splinter Review
Bug 29309: Make 'Pay all fines' be 'Pay all charges' (1.70 KB, patch)
2021-10-23 22:56 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 29309: (follow-up) Change 'Pay fines' to 'Pay charges' (1.30 KB, patch)
2021-10-23 22:56 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2021-10-22 15:40:15 UTC
It is inconsistent right now. They are not all fines, and that's why we should rename it.
Comment 1 Tomás Cohen Arazi 2021-10-22 22:01:54 UTC
Created attachment 126789 [details] [review]
Bug 29309: Make 'Pay all fines' be 'Pay all charges'

It is not just fines, it is also fees, etc.

To test:
1. Have a patron with debt
2. Go to the circulation page for the patron
=> FAIL: There's a button saying 'Pay all fines'
3. Apply this patch and reload page
=> SUCCESS: The button now says 'Pay all charges'
4. Enjoy the new terminology
5. Sign off :-D

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 2 David Nind 2021-10-23 20:07:18 UTC
Created attachment 126790 [details] [review]
Bug 29309: Make 'Pay all fines' be 'Pay all charges'

It is not just fines, it is also fees, etc.

To test:
1. Have a patron with debt
2. Go to the circulation page for the patron
=> FAIL: There's a button saying 'Pay all fines'
3. Apply this patch and reload page
=> SUCCESS: The button now says 'Pay all charges'
4. Enjoy the new terminology
5. Sign off :-D

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: David Nind <david@davidnind.com>
Comment 3 David Nind 2021-10-23 20:09:23 UTC
I love it when terminology inconsistencies are fixed up!

The current message "Checkouts are BLOCKED because fine balance is OVER THE LIMIT" needs fixing as well - I will create a separate bug for that.
Comment 4 Tomás Cohen Arazi 2021-10-23 20:42:01 UTC
(In reply to David Nind from comment #3)
> I love it when terminology inconsistencies are fixed up!
> 
> The current message "Checkouts are BLOCKED because fine balance is OVER THE
> LIMIT" needs fixing as well - I will create a separate bug for that.

Give me the right wording, and I'll write it as a patch on your behalf, as a follow-up here!
Comment 5 David Nind 2021-10-23 21:32:53 UTC
(In reply to Tomás Cohen Arazi from comment #4)

> Give me the right wording, and I'll write it as a patch on your behalf, as a
> follow-up here!

Options to change "Checkouts are BLOCKED because fine balance is OVER THE LIMIT":

1. Checkouts are BLOCKED because the amount owed is OVER THE LIMIT

2. Checkouts are BLOCKED because outstanding charges are OVER THE LIMIT

3. Checkouts are BLOCKED because the amount outstanding is OVER THE LIMIT

4. Checkouts are BLOCKED because the patron's balance is OVER THE LIMIT

5. Checkouts are BLOCKED because the balance for fees and charges is OVER THE LIMIT

I prefer option 4.

Thanks Tomás!
Comment 6 Katrin Fischer 2021-10-23 22:56:46 UTC
Created attachment 126792 [details] [review]
Bug 29309: Make 'Pay all fines' be 'Pay all charges'

It is not just fines, it is also fees, etc.

To test:
1. Have a patron with debt
2. Go to the circulation page for the patron
=> FAIL: There's a button saying 'Pay all fines'
3. Apply this patch and reload page
=> SUCCESS: The button now says 'Pay all charges'
4. Enjoy the new terminology
5. Sign off :-D

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2021-10-23 22:56:50 UTC
Created attachment 126793 [details] [review]
Bug 29309: (follow-up) Change 'Pay fines' to 'Pay charges'

Fixes another occurence of the fines to charges.

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Jonathan Druart 2021-10-25 13:59:26 UTC
Pushed to master for 21.11, thanks to everybody involved!
Comment 9 Martin Renvoize 2021-10-26 10:48:57 UTC
(In reply to David Nind from comment #5)
> (In reply to Tomás Cohen Arazi from comment #4)
> 
> > Give me the right wording, and I'll write it as a patch on your behalf, as a
> > follow-up here!
> 
> Options to change "Checkouts are BLOCKED because fine balance is OVER THE
> LIMIT":
> 
> 1. Checkouts are BLOCKED because the amount owed is OVER THE LIMIT
> 
> 2. Checkouts are BLOCKED because outstanding charges are OVER THE LIMIT
> 
> 3. Checkouts are BLOCKED because the amount outstanding is OVER THE LIMIT
> 
> 4. Checkouts are BLOCKED because the patron's balance is OVER THE LIMIT
> 
> 5. Checkouts are BLOCKED because the balance for fees and charges is OVER
> THE LIMIT
> 
> I prefer option 4.
> 
> Thanks Tomás!

The problem with these, and the original wording too, is that what we block on depends on preferences.. it's not the total outstanding balance, it's a subset of those charges... so we'd need something more generic I think.
Comment 10 Tomás Cohen Arazi 2021-10-26 13:14:01 UTC
(In reply to Martin Renvoize from comment #9)
> (In reply to David Nind from comment #5)
> > (In reply to Tomás Cohen Arazi from comment #4)
> > 
> > > Give me the right wording, and I'll write it as a patch on your behalf, as a
> > > follow-up here!
> > 
> > Options to change "Checkouts are BLOCKED because fine balance is OVER THE
> > LIMIT":
> > 
> > 1. Checkouts are BLOCKED because the amount owed is OVER THE LIMIT
> > 
> > 2. Checkouts are BLOCKED because outstanding charges are OVER THE LIMIT
> > 
> > 3. Checkouts are BLOCKED because the amount outstanding is OVER THE LIMIT
> > 
> > 4. Checkouts are BLOCKED because the patron's balance is OVER THE LIMIT
> > 
> > 5. Checkouts are BLOCKED because the balance for fees and charges is OVER
> > THE LIMIT
> > 
> > I prefer option 4.
> > 
> > Thanks Tomás!
> 
> The problem with these, and the original wording too, is that what we block
> on depends on preferences.. it's not the total outstanding balance, it's a
> subset of those charges... so we'd need something more generic I think.

Maybe we should address each scenario with the right wording? I'm all for that and willing to help.
Comment 11 Kyle M Hall 2021-10-29 13:42:17 UTC
Pushed to 21.05.x for 21.05.05
Comment 12 Fridolin Somers 2021-11-10 23:39:10 UTC
I prefer not to push to 20.11.x to minimize translation work.