Bug 29488 - NumSavedReports system preference doesn't work
Summary: NumSavedReports system preference doesn't work
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords: Manual
Depends on: 23013
Blocks: 29530
  Show dependency treegraph
 
Reported: 2021-11-15 20:04 UTC by Sara Brown
Modified: 2021-12-22 21:02 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
This fixes the saved reports page so that the NumSavedReports system preference works as intended - the number of reports listed should default to the value in the system preference (the initial default is 20).
Version(s) released in:
22.05.00,21.11.01,21.05.08


Attachments
Bug 29488: make NumSavedReports work (1.27 KB, patch)
2021-11-16 00:19 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 29488: make NumSavedReports work (1.33 KB, patch)
2021-11-16 15:08 UTC, PTFS Europe Sandboxes
Details | Diff | Splinter Review
Bug 29488: make NumSavedReports work (1.39 KB, patch)
2021-11-19 14:36 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sara Brown 2021-11-15 20:04:37 UTC
The NumSavedReports system preference to set a custom default number of reports to show in Saved Reports isn't working in 21.05.04. Changing the number, saving, and then refreshing Saved Reports (or leaving then reentering the module) doesn't change the number shown from the system default of 20.
Comment 1 Lucas Gass 2021-11-16 00:15:12 UTC
In dataTables version 1.10 we should use pageLength instead of iDisplayLength. 

https://datatables.net/reference/option/pageLength

Koha is using 1.10.18
Comment 2 Lucas Gass 2021-11-16 00:19:27 UTC
Created attachment 127677 [details] [review]
Bug 29488: make NumSavedReports work

1. Have a bunch of saved reports
2. Try to use the sys pref NumSavedReports to limit how many show by default
3. It doesn't work
4. Apply patch
5. Try again, now it should work
Comment 3 PTFS Europe Sandboxes 2021-11-16 15:08:39 UTC
Created attachment 127698 [details] [review]
Bug 29488: make NumSavedReports work

1. Have a bunch of saved reports
2. Try to use the sys pref NumSavedReports to limit how many show by default
3. It doesn't work
4. Apply patch
5. Try again, now it should work

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>
Comment 4 Katrin Fischer 2021-11-19 14:36:31 UTC
Created attachment 127871 [details] [review]
Bug 29488: make NumSavedReports work

1. Have a bunch of saved reports
2. Try to use the sys pref NumSavedReports to limit how many show by default
3. It doesn't work
4. Apply patch
5. Try again, now it should work

Signed-off-by: Barbara Johnson <barbara.johnson@bedfordtx.gov>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 5 Fridolin Somers 2021-12-02 06:53:17 UTC
I bet is is since Bug 23013
Comment 6 Fridolin Somers 2021-12-02 07:14:29 UTC
Pushed to master for 22.05, thanks to everybody involved!
Comment 7 Kyle M Hall 2021-12-03 14:58:28 UTC
Pushed to 21.11.x for 21.11.01
Comment 8 David Nind 2021-12-16 13:28:55 UTC
Added Manual keyword for 22.05 bugs that I consider require documentation changes. See bug 29640 and the linked spreadsheet for additional details.
Comment 9 Andrew Fuerste-Henry 2021-12-17 18:36:12 UTC
Pushed to 21.05.x for 21.05.08
Comment 10 Victor Grousset/tuxayo 2021-12-22 21:02:21 UTC
Not backported to oldoldstable (20.11.x). Feel free to ask if it's needed.