Bug 29641 - Upgrade to 21.06.00.012 [15:20:16]: Bug 15067 - Add missing languages ERROR: {UNKNOWN}: DBI Exception: DBD::mysql::db do failed: Duplicate entry 'IN-region' for key 'uniq_lang' at /usr/share/koha/lib/C4/Installer.pm line 738
Summary: Upgrade to 21.06.00.012 [15:20:16]: Bug 15067 - Add missing languages ERROR: ...
Status: RESOLVED DUPLICATE of bug 29631
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 21.11
Hardware: All Linux
: P5 - low blocker (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-04 13:35 UTC by Manos PETRIDIS
Modified: 2021-12-12 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Error message in CLI (40.79 KB, image/png)
2021-12-04 13:35 UTC, Manos PETRIDIS
Details
Error message in web interface (16.40 KB, image/png)
2021-12-04 13:35 UTC, Manos PETRIDIS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manos PETRIDIS 2021-12-04 13:35:04 UTC
Created attachment 128249 [details]
Error message in CLI

During both phase one (command line installer) and phase two (web-based installer) upgrade from 21.05.05-3 to 21.11.00-1 fails, throwing the following message:

Upgrade to 21.06.00.012 [15:25:02]: Bug 15067 - Add missing languages
ERROR: {UNKNOWN}: DBI Exception: DBD::mysql::db do failed: Duplicate entry 'IN-region' for key 'uniq_lang' at /usr/share/koha/lib/C4/Installer.pm line 738

Please advise.
Comment 1 Manos PETRIDIS 2021-12-04 13:35:35 UTC
Created attachment 128250 [details]
Error message in web interface
Comment 2 Manos PETRIDIS 2021-12-04 18:00:14 UTC
I wonder if it is related to https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29631
Comment 3 David Nind 2021-12-04 18:18:27 UTC
This is a duplicate of bug 29631 - the screens shots are helpful though!
Comment 4 Katrin Fischer 2021-12-06 00:14:44 UTC

*** This bug has been marked as a duplicate of bug 29631 ***