Bug 29812 - C4::Context not included, but used in Koha::Token
Summary: C4::Context not included, but used in Koha::Token
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 18124
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-06 18:24 UTC by Nick Clemens
Modified: 2022-02-20 17:25 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00,21.11.03,21.05.11


Attachments
Bug 29812: Add missing use C4::Context in Koha::Token (747 bytes, patch)
2022-01-07 10:30 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 29812: Add missing use C4::Context in Koha::Token (800 bytes, patch)
2022-01-07 12:24 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Clemens 2022-01-06 18:24:26 UTC

    
Comment 1 Jonathan Druart 2022-01-07 10:30:49 UTC
Created attachment 129134 [details] [review]
Bug 29812: Add missing use C4::Context in Koha::Token

Caused by bug 18124.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 2 Tomás Cohen Arazi 2022-01-07 12:24:09 UTC
Created attachment 129148 [details] [review]
Bug 29812: Add missing use C4::Context in Koha::Token

Caused by bug 18124.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 3 Fridolin Somers 2022-01-19 07:21:15 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 4 Kyle M Hall 2022-02-04 19:24:15 UTC
Pushed to 21.11.x for 21.11.03
Comment 5 Andrew Fuerste-Henry 2022-02-11 18:16:02 UTC
Pushed to 21.05.x for 21.05.11
Comment 6 Victor Grousset/tuxayo 2022-02-20 17:25:21 UTC
Not backported to oldoldstable (20.11.x). Feel free to ask if it's needed.