Bug 29854 - ES timeout is not configurable
Summary: ES timeout is not configurable
Status: RESOLVED DUPLICATE of bug 29856
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching - Elasticsearch (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-12 08:09 UTC by Jonathan Druart
Modified: 2022-01-12 09:58 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Druart 2022-01-12 08:09:40 UTC
Using the sandboxes system I am getting a timeout during the commit request.
This is the 'request_timeout' parameter that is defaulting to 30
https://metacpan.org/pod/Search::Elasticsearch::Role::Cxn#request_timeout

Setting it to 60 resolved the problem. We should make this value configurable.
Comment 1 Jonathan Druart 2022-01-12 09:58:56 UTC

*** This bug has been marked as a duplicate of bug 29856 ***