Bug 30104 - Holds to pull is broken
Summary: Holds to pull is broken
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Tomás Cohen Arazi
URL:
Keywords:
Depends on: 29844
Blocks:
  Show dependency treegraph
 
Reported: 2022-02-14 23:13 UTC by Lucas Gass
Modified: 2022-02-18 13:00 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 30104: (bug 29844 follow-up): Fix holds to pull (926 bytes, patch)
2022-02-15 07:47 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 30104: (bug 29844 follow-up): Fix holds to pull (980 bytes, patch)
2022-02-15 14:57 UTC, Lucas Gass
Details | Diff | Splinter Review
Bug 30104: (bug 29844 follow-up): Fix holds to pull (1.01 KB, patch)
2022-02-16 11:22 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Gass 2022-02-14 23:13:43 UTC
TO recreate:

Go to Holds to Pull and see this error:

The method Koha::Items->biblionumber is not covered by tests!

Trace begun at /kohadevbox/koha/Koha/Objects.pm line 572
Comment 1 Lucas Gass 2022-02-14 23:15:11 UTC
Maybe this is also caused by Bug 29844?
Comment 2 Jonathan Druart 2022-02-15 07:47:11 UTC
Created attachment 130593 [details] [review]
Bug 30104: (bug 29844 follow-up): Fix holds to pull

There was an error when circ/pendingreserves.pl was hit:
The method Koha::Items->biblionumber is not covered by tests!
Comment 3 Lucas Gass 2022-02-15 14:57:24 UTC
Created attachment 130620 [details] [review]
Bug 30104: (bug 29844 follow-up): Fix holds to pull

There was an error when circ/pendingreserves.pl was hit:
The method Koha::Items->biblionumber is not covered by tests!

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Comment 4 Tomás Cohen Arazi 2022-02-16 11:22:50 UTC
Created attachment 130660 [details] [review]
Bug 30104: (bug 29844 follow-up): Fix holds to pull

There was an error when circ/pendingreserves.pl was hit:
The method Koha::Items->biblionumber is not covered by tests!

Signed-off-by: Lucas Gass <lucas@bywatersolutions.com>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 5 Fridolin Somers 2022-02-17 07:53:01 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄