Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims
Summary: Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for ...
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 21.05
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Testopia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-14 10:58 UTC by Kyle M Hall
Modified: 2022-04-25 21:03 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:
21.05.14


Attachments
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims (1.69 KB, patch)
2022-04-14 11:01 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims (1.69 KB, patch)
2022-04-14 11:02 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims (1.74 KB, patch)
2022-04-15 13:44 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims (1.81 KB, patch)
2022-04-18 16:36 UTC, Andrew Fuerste-Henry
Details | Diff | Splinter Review
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims (1.86 KB, patch)
2022-04-19 07:45 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2022-04-14 10:58:24 UTC
Basically, if MarkLostItemsAsReturned is set for return claims, the code will crash while trying to pull the checkout so it can update the lost status of the item. This is because the code assumes there must be a checkout and never checks the old_checkouts table.

This bug appears to only exist in 21.11 at this time. It was fixed by a combination of bugs 29495 and 28588.
Comment 1 Kyle M Hall 2022-04-14 11:01:12 UTC
Created attachment 133300 [details] [review]
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims

Basically, if MarkLostItemsAsReturned is set for return claims, the code will crash while trying to pull the checkout so it can update the lost status of the item. This is because the code assumes there must be a checkout and never checks the old_checkouts table.

This bug appears to only exist in 21.05 at this time. It was fixed by a combination of bugs 29495 and 28588.

Test Plan:
1) Set MarkLostItemsAsReturned for return claims
2) Mark a checkout as claims returned
3) Verify the checkout is no longer on the patron record
4) Resolve the claim
5) Note the attempt "hangs" but refreshing the page shows it worked
6) Apply this patch, restart all the things!
7) Repeat steps 2-4
8) It works!
Comment 2 Kyle M Hall 2022-04-14 11:02:00 UTC
Typo, this bug appears to only exist in 21.05 at this time. Not 21.11 as previously stated.
Comment 3 Kyle M Hall 2022-04-14 11:02:35 UTC
Created attachment 133301 [details] [review]
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims

Basically, if MarkLostItemsAsReturned is set for return claims, the code will crash while trying to pull the checkout so it can update the lost status of the item. This is because the code assumes there must be a checkout and never checks the old_checkouts table.

This bug appears to only exist in 21.05 at this time. It was fixed by a combination of bugs 29495 and 28588.

Test Plan:
1) Set MarkLostItemsAsReturned for return claims
2) Mark a checkout as claims returned
3) Verify the checkout is no longer on the patron record
4) Resolve the claim
5) Note the attempt "hangs" but refreshing the page shows it worked
6) Apply this patch, restart all the things!
7) Repeat steps 2-4
8) It works!
Comment 4 Andrew Fuerste-Henry 2022-04-15 13:44:47 UTC
Created attachment 133357 [details] [review]
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims

Basically, if MarkLostItemsAsReturned is set for return claims, the code will crash while trying to pull the checkout so it can update the lost status of the item. This is because the code assumes there must be a checkout and never checks the old_checkouts table.

This bug appears to only exist in 21.05 at this time. It was fixed by a combination of bugs 29495 and 28588.

Test Plan:
1) Set MarkLostItemsAsReturned for return claims
2) Mark a checkout as claims returned
3) Verify the checkout is no longer on the patron record
4) Resolve the claim
5) Note the attempt "hangs" but refreshing the page shows it worked
6) Apply this patch, restart all the things!
7) Repeat steps 2-4
8) It works!

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Comment 5 Andrew Fuerste-Henry 2022-04-18 16:36:59 UTC
Created attachment 133377 [details] [review]
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims

Basically, if MarkLostItemsAsReturned is set for return claims, the code will crash while trying to pull the checkout so it can update the lost status of the item. This is because the code assumes there must be a checkout and never checks the old_checkouts table.

This bug appears to only exist in 21.05 at this time. It was fixed by a combination of bugs 29495 and 28588.

Test Plan:
1) Set MarkLostItemsAsReturned for return claims
2) Mark a checkout as claims returned
3) Verify the checkout is no longer on the patron record
4) Resolve the claim
5) Note the attempt "hangs" but refreshing the page shows it worked
6) Apply this patch, restart all the things!
7) Repeat steps 2-4
8) It works!

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>

Signed-off-by: Christine Lee <chlee@pascolibraries.org>
Comment 6 Martin Renvoize 2022-04-19 07:45:25 UTC
Created attachment 133387 [details] [review]
Bug 30541 - Resolve return claim works but "hangs" if MarkLostItemsAsReturned is set for return claims

Basically, if MarkLostItemsAsReturned is set for return claims, the code will crash while trying to pull the checkout so it can update the lost status of the item. This is because the code assumes there must be a checkout and never checks the old_checkouts table.

This bug appears to only exist in 21.05 at this time. It was fixed by a combination of bugs 29495 and 28588.

Test Plan:
1) Set MarkLostItemsAsReturned for return claims
2) Mark a checkout as claims returned
3) Verify the checkout is no longer on the patron record
4) Resolve the claim
5) Note the attempt "hangs" but refreshing the page shows it worked
6) Apply this patch, restart all the things!
7) Repeat steps 2-4
8) It works!

Signed-off-by: Andrew Fuerste-Henry <andrew@bywatersolutions.com>
Signed-off-by: Christine Lee <chlee@pascolibraries.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 7 Martin Renvoize 2022-04-19 07:47:07 UTC
Simple fix that causes no regressions.

Passing QA
Comment 8 Victor Grousset/tuxayo 2022-04-25 21:03:20 UTC
Note about oldstable: It has been pushed to 21.05.x for 21.05.14
Comment 9 Victor Grousset/tuxayo 2022-04-25 21:03:27 UTC
Not backported to oldoldstable (20.11.x). Feel free to ask if it's needed.