Bug 30890 - ILL breadcrumbs are wrong
Summary: ILL breadcrumbs are wrong
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: ILL (show other bugs)
Version: 21.11
Hardware: All All
: P5 - low minor (vote)
Assignee: Isobel Graham
QA Contact:
URL:
Keywords:
: 31494 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-06-02 13:37 UTC by Magnus Enger
Modified: 2022-11-25 00:08 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.11.00, 22.05.07, 21.11.14


Attachments
Bug 30890: Fixed ILL breadcrumb (1.37 KB, patch)
2022-09-01 11:14 UTC, Isobel Graham
Details | Diff | Splinter Review
Bug 30890: Fixed ILL breadcrumb (1.42 KB, patch)
2022-09-07 11:46 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 30890: Fixed ILL breadcrumb (1.47 KB, patch)
2022-09-07 13:02 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Enger 2022-06-02 13:37:31 UTC
To reproduce: 

- Make sure you have the ILL module set up, with at least one active request
- Click on "Manage request" for a request

You are now on a page like /cgi-bin/koha/ill/ill-requests.pl?method=illview&illrequest_id=1766

The breadcrumbs are "Home > ILL requests" and "ILL requests" is a link to the same page you are on. 

I would expect the breadcrumbs to be something like "Home > ILL requests > Manage request number 1766", with "ILL requests" being a link to /cgi-bin/koha/ill/ill-requests.pl (same as the "List requests" button).
Comment 1 Martin Renvoize 2022-09-01 10:39:22 UTC
*** Bug 31494 has been marked as a duplicate of this bug. ***
Comment 2 Isobel Graham 2022-09-01 11:14:32 UTC
Created attachment 140037 [details] [review]
Bug 30890: Fixed ILL breadcrumb

Added correct breadrumb depth when managing requests.

1. Viewing a request on a ILL request page
2. Making sure the breadcrumb has three depths
   and the manage requests has the correct
   request id
Comment 3 Owen Leonard 2022-09-01 11:49:56 UTC
-        [% ELSIF query_type == 'status' %]
+        [% ELSIF query_type == 'illview' %]

Is the "status" query_type not used for anything?
Comment 4 Martin Renvoize 2022-09-05 11:26:28 UTC
(In reply to Owen Leonard from comment #3)
> -        [% ELSIF query_type == 'status' %]
> +        [% ELSIF query_type == 'illview' %]
> 
> Is the "status" query_type not used for anything?

It's a good question.. as far as I can tell from the controller query_type will never be returned with a value of 'status'.  I tried digging through the git logs to see when it was introduced or changed, but it appears to have never been returned going as far back as the original introduction of ILL into core Koha.
Comment 5 Owen Leonard 2022-09-07 11:46:55 UTC
Created attachment 140277 [details] [review]
Bug 30890: Fixed ILL breadcrumb

Added correct breadrumb depth when managing requests.

1. Viewing a request on a ILL request page
2. Making sure the breadcrumb has three depths
   and the manage requests has the correct
   request id

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 6 Katrin Fischer 2022-09-07 13:02:06 UTC
Created attachment 140280 [details] [review]
Bug 30890: Fixed ILL breadcrumb

Added correct breadrumb depth when managing requests.

1. Viewing a request on a ILL request page
2. Making sure the breadcrumb has three depths
   and the manage requests has the correct
   request id

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Tomás Cohen Arazi 2022-09-22 11:25:02 UTC
Pushed to master for 22.11.

Nice work everyone, thanks!
Comment 8 Lucas Gass 2022-10-31 22:40:32 UTC
Backported to 22.05.x for upcoming 22.05.07 release
Comment 9 Arthur Suzuki 2022-11-14 16:47:33 UTC
applied to 21.11 for 21.11.14
Comment 10 Victor Grousset/tuxayo 2022-11-25 00:08:35 UTC
Not backported to oldoldstable (21.05.x). Feel free to ask if it's needed.

Nothing to document it seems, marking resolved.