Bug 3265 - LOST status not changed after issued item is checked in
Summary: LOST status not changed after issued item is checked in
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-28 03:04 UTC by Mickey Coalwell
Modified: 2012-10-25 22:52 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:08:28 UTC


---- Reported by mcoalwell@nekls.org 2009-05-28 03:04:39 ----

When a checked out item is converted to LOST status and goes on to the borrower's fine account with a replacement cost, and that lost item is subsequently returned and checked in, Koha now automatically issues a credit for the lost item in the amount of the replacement cost so that the patron is not charged for a lost item that's returned. However, the item status doesn't change to Available. It remains Lost. I'm thinking that once the item is returned, the Lost status should come off. 

Patron Fine Record shows item is no longer Lost, replacement cost is credited...

Date  	Description of charges  	Amount  	Outstanding
05/27/2009 	Lost Item 0003008001067 View item  Small change, big problems : 	$25.95 	$0.00
05/27/2009 	Item Returned   	$-25.95 	$0.00


...but item still displays in catalog with Lost status

Item type  	Home Location  	Collection  	Call Number  	Status  	Last seen  	Barcode
BOOK 	NEKLS 	NON-FICTION 	025.1 SNY 	Lost 	05/27/2009 	0003008001067



---- Additional Comments From mcoalwell@nekls.org 2009-06-09 15:56:45 ----

(In reply to comment #0)


Requesting higher severity on this item as we are moving towards using longoverdues.pl cron script to trigger LOST status changes on patron accounts.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:08 UTC  ---

This bug was previously known as _bug_ 3265 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3265

Actual time not defined. Setting to 0.0

Comment 1 Liz Rea 2010-05-27 16:14:47 UTC
This is still an issue in HEAD as of 5/27/2010.

The status is changed, but not changed to available. The status field for the item is empty. 

Screenshots to follow.
Comment 2 Owen Leonard 2010-07-02 20:08:18 UTC
Is the patch for Bug 3781 relevent to this bug? 3781 looks like a duplicate of this one.

Patch here: http://lists.koha-community.org/pipermail/koha-patches/2009-November/010452.html
Comment 3 Liz Rea 2010-07-06 15:06:08 UTC
This appears to be fixed. I just checked out a book, marked it lost, fines were applied; I returned the book, it was marked not lost, status available, and taken off of my account. This seems like perfect behavior to me.

Closing with always the option to reopen.