Bug 3343 - duplicate subfields in authority
Summary: duplicate subfields in authority
Status: CLOSED DUPLICATE of bug 17908
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: rel_3_0
Hardware: PC All
: P5 - low minor (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-19 03:15 UTC by Chris Cormack
Modified: 2017-01-14 11:09 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:09:22 UTC


---- Reported by laurence.lefaucheur@biblibre.com 2009-06-19 15:15:00 ----

If an authority has duplicate subdivisions for instance : 

250 ## - Vedette-Matière nom commun
  a Elément d'entrée cerise
  x Subdivision de sujet stark
  y Subdivision géograp Bessenay
  y Subdivision géograp Rhône
  x Subdivision de sujet guide de recettes

(the order of subdivisions has importance)

When addind this authority in biblio, duplicate subfields are grouped separated with | : 
  in biblio : cerisier -- stark|guide de recettes -- Bessenay|Rhône

The order and subfields should be preserved in biblio.

--------------------
Inversely : 
when authority like this is directly created through biblio (with biblioaddsauthorities), authority is ok, with subfields in order

---------------------
but when authority is added in biblio : 

 606 ## - Sujet nom commun
  a élément d'entrée France Autor.
  x subdivision du sujet Conditions économiques
  z subdivision chronologique 1900-1945
  x subdivision du sujet Périodiques 

and then created through script build_authorities.pl, authority entry has duplicated subfields in one subfield separated with pipe : 

250 ## - Vedette-Matière nom commun
  a Elément d'entrée France
  x Subdiv. de sujet Conditions économiques|Périodiques
  z Subdiv. chronologiqu 1900-1945



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:09 UTC  ---

This bug was previously known as _bug_ 3343 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3343

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was laurence.lefaucheur@biblibre.com.

Comment 1 Marcel de Rooy 2017-01-14 11:09:36 UTC
Closing this one in favor of the current bugs in omnibus bug 17908

*** This bug has been marked as a duplicate of bug 17908 ***