Bug 3468 - Enhanced patron searching, patron batch edit/delete
Summary: Enhanced patron searching, patron batch edit/delete
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement with 10 votes (vote)
Assignee: Jane Wagner
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-02 03:25 UTC by Jane Wagner
Modified: 2014-12-07 20:03 UTC (History)
7 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Search screenshot (50.19 KB, image/jpeg)
2009-08-02 15:25 UTC, Chris Cormack
Details
borrower cart screenshot (36.35 KB, image/jpeg)
2009-08-02 15:25 UTC, Chris Cormack
Details
borrower cart confirm screenshot (28.64 KB, image/jpeg)
2009-08-02 15:26 UTC, Chris Cormack
Details
borrower batch edit screenshot (29.09 KB, image/jpeg)
2009-08-02 15:27 UTC, Chris Cormack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:11:02 UTC


---- Reported by jwagner@ptfs.com 2009-08-02 15:25:27 ----

Created an attachment
Search screenshot

Sponsored by East Brunswick Public Library, East Brunswick, NJ, USA.

Enhance patron search by adding options to allow partial searches of email and phone, and a direct SQL query in the bottom box.  (Per discussion on the listserv and IRC, display of the SQL query will be controlled by a syspref.  However, it is read-only and only brings results up into the standard patron search hitlist.)

Add borrower cart function to collect selected patron records for batch edit and batch delete.  A syspref allows setting of a fine threshold; patrons with fines above that limit are blocked from deletion, as are patrons with current checkouts.  In conjunction with another sponsored enhancement, patrons in debt collection are also blocked.

Batch edit allows changes to address and other patron fields, and allows deletion (emptying) circ and OPAC note fields.

Both batch edit and batch delete have "are you sure" prompts before action is taken.



---- Additional Comments From jwagner@ptfs.com 2009-08-02 15:25:59 ----

Created an attachment
borrower cart screenshot





---- Additional Comments From jwagner@ptfs.com 2009-08-02 15:26:35 ----

Created an attachment
borrower cart confirm screenshot





---- Additional Comments From jwagner@ptfs.com 2009-08-02 15:27:04 ----

Created an attachment
borrower batch edit screenshot





---- Additional Comments From nengard@gmail.com 2009-08-19 19:38:11 ----

Wasn't there some discussion on this topic - was it on the mailing list? Anyway, I'm for not showing the SQL here - and making the search look more simple - just cause it can be a bit confusing to the average circ librarian (or any non-programmer) to see SQL when searching for a patron record.



---- Additional Comments From dschust1@gmail.com 2009-08-31 16:32:33 ----

(In reply to comment #2)
> Created an attachment [details]
> borrower cart confirm screenshot
> 

If there is an item still checked out what happens to this borrower and the item? or if they have fines?

Does this enhancement allow you to "edit" additional borrower attributes?



---- Additional Comments From jwagner@ptfs.com 2009-08-31 21:07:07 ----

The feature will not delete patrons with items currently checked out.  There is a syspref BatchMemberDeleteFineThreshhold where you can set a threshold for outstanding fines.  Under that amount, the patron can be deleted; over it, the delete won't happen.  

If the patron has a hold, the hold will be deleted when the patron is deleted.

Display of the SQL search option is controlled by a syspref ShowPatronSearchBySQL.  The SQL search has the first part (select...) hardcoded and will strip out anything after a semicolon as a precaution.



---- Additional Comments From mjr@ttllp.co.uk 2009-09-07 10:11:35 ----

I'm confused.  I see screenshot attachments, but no patch.  Has the patch for this been posted?




---- Additional Comments From mjr@ttllp.co.uk 2009-09-07 10:18:33 ----

*** http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3332 has been marked as a duplicate of this bug. ***



---- Additional Comments From mjr@ttllp.co.uk 2009-09-07 14:32:30 ----

Not sure if this is part of this enhancement or a new separate one:

The "Browse by last name" should include whatever non-latin-alnum characters actually occur at the start of a surname.




---- Additional Comments From jwagner@ptfs.com 2009-09-08 12:27:04 ----

The screenshots are from our current development/testing; we're still tweaking a few final things, so the patch hasn't made it out yet.



---- Additional Comments From jwagner@ptfs.com 2010-05-12 12:16:46 ----

The fix for this bug can be pulled from the public git repository at http://github.com/Koha-PTFS, branch http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3468 (ptfs-harley)



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:11 UTC  ---

This bug was previously known as _bug_ 3468 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3468
Imported an attachment (id=1322)
Imported an attachment (id=1323)
Imported an attachment (id=1324)
Imported an attachment (id=1325)

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was kohaprogrammers@ptfs.com.
CC member mjr@ttllp.co.uk does not have an account here
The original submitter of attachment 1322 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1323 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1324 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1325 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 MJ Ray (software.coop) 2010-07-07 19:27:07 UTC
Restoring where "Previous assignee was mjr@ttllp.co.uk"
Comment 2 Nicole C. Engard 2011-01-04 20:43:09 UTC
please attach the patch as the links below no longer work.
Comment 3 Marcel de Rooy 2011-01-31 12:53:21 UTC
Resetting patch status, since signing a patch that you cannot find is somewhat difficult ;)
Comment 4 Jane Wagner 2011-06-30 16:46:14 UTC
Note from Harley integration page: 3.4 cherry-picked onto master, pushed to http://git.koha-community.org/gitweb/?p=koha.git;a=shortlog;h=refs/heads/new/ptfs_patron_features
Comment 5 Katrin Fischer 2013-04-13 21:47:20 UTC
We now have a tool for batch editing of patrons and new options for patron search.

The development described here would probably need a major rewrite/have to be rewritten to fit into our current code base. 

As there is a partial fix I will close this bug. Please open new bugs for features still missing.