Bug 3475 - Add copy patron function
Summary: Add copy patron function
Status: CLOSED DUPLICATE of bug 5432
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: PC All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Jane Wagner
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-02 05:46 UTC by Jane Wagner
Modified: 2012-10-26 00:41 UTC (History)
2 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Copy patron screenshot (35.05 KB, image/jpeg)
2009-08-02 17:46 UTC, Chris Cormack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:11:07 UTC


---- Reported by jwagner@ptfs.com 2009-08-02 17:46:12 ----

Created an attachment
Copy patron screenshot

Sponsored by East Brunswick Public Library, East Brunswick, NJ, USA.

In patron display, added an option under More toolbar button to copy existing patron.  Adds a new patron record, copying data from current patron except for first name and barcode.  Useful for adding family members and/or people at the same address.



---- Additional Comments From jwagner@ptfs.com 2010-05-12 12:31:01 ----

The fix for this bug (in ptfs-harley) can be pulled from the public git repository at http://github.com/Koha-PTFS, branch http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3475



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:11 UTC  ---

This bug was previously known as _bug_ 3475 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3475
Imported an attachment (id=1339)

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was kohaprogrammers@ptfs.com.
The original submitter of attachment 1339 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-12-31 17:25:44 UTC
A fix for Bug 3475 can be found in the ip-bug-3475-patron-copy-2010-12-31 branch at http://gitorious.org/koha-dev/koha-dev

This branch cherry-picks the functionality added in ptfs/Bug3457 and adds some corrections to get it working.
Comment 2 MJ Ray (software.coop) 2011-01-07 11:12:52 UTC
This bug is mentioned in:
Pull request for Bug 3475 http://lists.koha-community.org/pipermail/koha-patches/2010-December/013491.html
Comment 3 Nicole C. Engard 2011-03-07 18:21:01 UTC
Bug 5432 has been pushed to master and adds this same functionality.

*** This bug has been marked as a duplicate of bug 5432 ***