Bug 3628 - Add opacSerialDefaultTab preference to display shortened serial collection instead of holdings by default
Summary: Add opacSerialDefaultTab preference to display shortened serial collection in...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Henri-Damien LAURENT
QA Contact:
URL:
Keywords:
: 4178 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-15 12:33 UTC by Chris Cormack
Modified: 2014-05-26 21:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Partial fix (1.52 KB, patch)
2011-03-31 10:49 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Signed off patch (1.56 KB, patch)
2011-04-04 11:56 UTC, claire.hernandez@biblibre.com
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:13:03 UTC


---- Reported by laurence.lefaucheur@biblibre.com 2009-09-15 12:33:19 ----

Developed functionalities not pushed in 3.2 : 

- Lack of search history functionality in opac (exists on am123-dev)
- lack of filter in koha/opac-serial-issues.pl (allow to filter serial collection by branch)
- lack of syspref opacSerialDefaultTab and corresponding patch (to display shortened serial collection instead of holdings in default opac normal display)



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:13 UTC  ---

This bug was previously known as _bug_ 3628 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3628

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was laurence.lefaucheur@biblibre.com.

Comment 1 Owen Leonard 2010-06-08 18:18:50 UTC
> - Lack of search history functionality in opac (exists on am123-dev)

Now in HEAD
> - lack of filter in koha/opac-serial-issues.pl (allow to filter serial
> collection by branch)

Now in HEAD

> - lack of syspref opacSerialDefaultTab and corresponding patch (to display
> shortened serial collection instead of holdings in default opac normal display)

Still missing. Updating bug to limit it to this issue.
Comment 2 Magnus Enger 2011-02-11 09:35:42 UTC
*** Bug 4178 has been marked as a duplicate of this bug. ***
Comment 3 Marcel de Rooy 2011-03-31 10:48:04 UTC
Sending a partial fix to make this existing pref visible, as already discovered by Nicole in bug 4178.
The code in opac-detail.pl for the Serial Collection tab currently only applies to UNIMARC. Some work still need to be done..
Comment 4 Marcel de Rooy 2011-03-31 10:49:30 UTC
Created attachment 3570 [details] [review]
Partial fix

Make this pref visible.
Comment 5 claire.hernandez@biblibre.com 2011-04-04 10:05:09 UTC
What I do to test:
- apply the patch
- adding a subscription (with 955$9 955$r too)
- move syspref to each cases and refresh opac biblio page to see the default tab change

Ok for me.
Comment 6 claire.hernandez@biblibre.com 2011-04-04 10:07:27 UTC
(In reply to comment #5)
> What I do to test:
> - apply the patch
> - adding a subscription (with 955$9 955$r too)
> - move syspref to each cases and refresh opac biblio page to see the default
> tab change
> 
> Ok for me.

(I worked with a unimarc database)
Comment 7 claire.hernandez@biblibre.com 2011-04-04 11:56:30 UTC
Created attachment 3616 [details] [review]
Signed off patch
Comment 8 Chris Cormack 2011-04-04 22:15:16 UTC
Pushed, please note this only works for UNIMARC
Comment 9 Jared Camins-Esakov 2012-12-31 00:02:03 UTC
There have been no further reports of problems so I am marking this bug resolved.
Comment 10 vimal kumar 2013-05-29 04:09:52 UTC
Administration › System preferences> opacSerialDefaultTab > Subscription Tab does not save.I felt this problem in 3.12.00.
The result is serial display in OPAC missing issue details in first view.

Any progress in solve this problem?