Bug 3679 - Specify Reply-To address when emailing a list or cart from OPAC
Summary: Specify Reply-To address when emailing a list or cart from OPAC
Status: RESOLVED DUPLICATE of bug 2234
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on: 10269
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 04:37 UTC by David Schuster
Modified: 2020-04-09 06:01 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:13:38 UTC


---- Reported by dschust1@gmail.com 2009-09-30 16:37:14 ----

I would like the form to ask for an email address so that the receiver of the email actually knows who sent this cart/list.

Currently the system defaults to the "default system" email which is mine so people are wanting to know what to do with the list I sent them.

Otherwise put wording asking the person to put their email in the comments box at least if they are emailing someone other than themselves.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:13 UTC  ---

This bug was previously known as _bug_ 3679 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3679

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0

Comment 1 Owen Leonard 2011-12-30 20:16:57 UTC
As long as the OPAC requires that the user be logged in to email a cart or a list I would think it would be simple to use the logged-in user's primary email address, assuming they have one.
Comment 2 Katrin Fischer 2013-01-28 13:00:09 UTC
I think we could set the reply to address to the patron's email address. Setting the 'from' to the patron's address is likely to cause problems with some mail servers refusing the email (speaking out of experience).

I wonder if this has already been done on a separate bug?
Comment 3 Katrin Fischer 2019-05-04 14:34:34 UTC
I am changing From to Reply-To for the reason noted in comment 2.
Comment 4 Martin Renvoize 2020-04-09 06:01:24 UTC

*** This bug has been marked as a duplicate of bug 2234 ***