Bug 4151 - Document new perl modules for those upgrading
Summary: Document new perl modules for those upgrading
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: rel_3_2
Hardware: PC All
: P5 - low blocker (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 04:22 UTC by Liz Rea
Modified: 2019-06-27 09:24 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch for typos in migration_tools (1.25 KB, patch)
2010-03-03 16:15 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:23:44 UTC


---- Reported by wizzyrea@gmail.com 2010-02-10 16:22:14 ----

Please "write up or otherwise handle instructions for installing new perl modules that were since 3.0.0"

I know JSON is the one that tripped me up.



---- Additional Comments From gmcharlt@gmail.com 2010-02-10 16:26:33 ----

Marking as blocker, as the instructions need to be in place before 3.2 beta is released.



---- Additional Comments From braedon@tw.co.nz 2010-02-11 23:02:14 ----

To install Koha git master (as of today) on a fresh Ubuntu 9.10 install I found I required the following perl modules from the repositories:

libalgorithm-checkdigits-perl
libauthen-cas-client-perl
libbiblio-endnotestyle-perl
libdbd-sqlite2-perl
libemail-date-perl
graphicsmagick
libgraphics-magick-perl
libhtml-scrubber-perl
libjson-perl
liblingua-stem-snowball-perl
libmarc-crosswalk-dublincore-perl
libnumber-format-perl
libpdf-table-perl
libxml-sax-writer-perl

libyaml-perl - Not sure if it is required for Koha itself, but needed for make test to run sucessfully

The following were required from CPAN:

HTTP::OAI
IPC::Cmd
Memoize::Memcached
Storable
Test::More
Text::CSV::Encoded

Authen::CAS::Client - Didn't want to install from cpan - worked on cpanp
Module::Install - Needed to install PDF::API2::Simple, but not in it's dependency list for some reason
PDF::API2::Simple - Didn't want to install from cpan - worked on cpanp



---- Additional Comments From wizzyrea@gmail.com 2010-02-15 15:38:21 ----

I might add Lingua::Stem::Snowball



---- Additional Comments From gmcharlt@gmail.com 2010-02-17 10:05:14 ----

Replaced dep on YAML::XS with YAML::Syck (opac/oai.pl)



---- Additional Comments From gmcharlt@gmail.com 2010-02-17 11:47:57 ----

new dep: Locale::Currency::Format



---- Additional Comments From braedon@tw.co.nz 2010-02-17 19:51:34 ----

Quick adjustment to my list of ubuntu packages.

Turns out Module::Install is available in the repositories as libmodule-install-perl - for some reason I didn't check that one - so it should be moved from the list of CPAN modules to the repository modules.



---- Additional Comments From dschust1@gmail.com 2010-03-02 00:46:10 ----

(In reply to comment #1)
> Marking as blocker, as the instructions need to be in place before 3.2 beta is
> released.

Another item needed to be changed in the install instructions is misc/migration-tools/rebuild_zebra.pl - should be misc/migration_tools/rebuild_zebra.pl - in the INSTALL.debian-lenny instructions at least.



---- Additional Comments From dschust1@gmail.com 2010-03-02 20:50:04 ----

(In reply to comment #7)
> (In reply to comment #1)
> > Marking as blocker, as the instructions need to be in place before 3.2 beta is
> > released.
> 
> Another item needed to be changed in the install instructions is
> misc/migration-tools/rebuild_zebra.pl - should be
> misc/migration_tools/rebuild_zebra.pl - in the INSTALL.debian-lenny
> instructions at least.
> 

Following the instructions for 3.2 on a fresh lenny install - INSTALL.debian-lenny - I had these issues:

cpan PDF::API2::Simple - wouldn't make until I did cpan Module::Install

There were other dependancies needed as well

Authen::CAS::Client

Also look at the Zebra fast index section - $ misc/migration-tools/rebuild_zebra.pl -b -w  to get it to run I had to have -v as well.



---- Additional Comments From dschust1@gmail.com 2010-03-02 20:50:26 ----

*** http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4146 has been marked as a duplicate of this bug. ***



---- Additional Comments From gmcharlt@gmail.com 2010-03-03 15:59:33 ----

Another missing dependency found by ccurry:

Net::Server::PreFork - required if using SIP2

libnet-server-perl on Debian-ish distros



---- Additional Comments From wizzyrea@gmail.com 2010-03-03 16:15:11 ----

Created an attachment
Proposed patch for typos in migration_tools





---- Additional Comments From tajoli@cilea.it 2010-03-18 08:13:13 ----

The module Text::CSV::Encoded need to be installed by CPAN, not present
on Debian lenny.
Until now, not listed in INSTALL.debian-lenny 



---- Additional Comments From colin.campbell@ptfs-europe.com 2010-03-31 10:04:22 ----

Two modules required by the sip implementation that are currently not included in dependencies (and not used elsewhere so you don't find out uintil you run the sipserver) are

Net::Server (includes PreFork as noted above)
UNIVERSAL::require





---- Additional Comments From nengard@gmail.com 2010-04-29 15:14:28 ----

*** http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4320 has been marked as a duplicate of this bug. ***



---- Additional Comments From tajoli@cilea.it 2010-04-30 08:33:50 ----

From Feb 2010 the version 3.0. needs the module Text::CSV::Encoded.

This module is not present in the package repositories of 
Debian and Ubuntu.

Specific checks done on:
- Debian lenny
- Ubuntu hardy
- Ubuntu intrepid
- Ubuntu jaunty
- Ubuntu karmic

So we need to update the list of perl modules to install with CPAN in the files
INSTALL.debian-lenny and INSTALL.ubuntu.

Is not clear the situation for OpenSuse and Fedora.



---- Additional Comments From colin.campbell@ptfs-europe.com 2010-04-30 09:08:47 ----

Re Fedora (& Centos) see http://tinyurl.com/35m3mzn for links to spreadsheets giving rpm coverage for CPAN modules for those platforms and a link to an associated project on github



---- Additional Comments From colin.campbell@ptfs-europe.com 2010-05-03 15:44:26 ----

Another missing dependency. DateTime is used at one point in the sip routines.



---- Additional Comments From gmcharlt@gmail.com 2010-05-03 17:14:58 ----

(In reply to comment #17)
> Another missing dependency. DateTime is used at one point in the sip routines.
> 

Pushed.



---- Additional Comments From gmcharlt@gmail.com 2010-05-17 14:50:47 ----

(In reply to comment #7)
> (In reply to comment #1)
> > Marking as blocker, as the instructions need to be in place before 3.2 beta is
> > released.
> 
> Another item needed to be changed in the install instructions is
> misc/migration-tools/rebuild_zebra.pl - should be
> misc/migration_tools/rebuild_zebra.pl - in the INSTALL.debian-lenny
> instructions at least.
> 

Pushed fix for the typo.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:23 UTC  ---

This bug was previously known as _bug_ 4151 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4151
Imported an attachment (id=1876)

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
CC member braedon@tw.co.nz does not have an account here
CC member jwagner@ptfs.com does not have an account here
The original submitter of attachment 1876 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Chris Cormack 2010-05-22 05:01:07 UTC
This has been fixed by the work of Chris Nighswonger, in bug 4444