Bug 4202 - Improve international currency and exchange support
Summary: Improve international currency and exchange support
Status: RESOLVED MOVED
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-17 04:23 UTC by Chris Nighswonger
Modified: 2019-05-04 13:44 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:24:21 UTC


---- Reported by cnighswonger@foundations.edu 2010-02-17 04:23:38 ----

Re-factor currency and exchange rate support within Koha using Locale::Currency::Format and Finance::Quote.

This will allow:
1. the use of a single system preference to set the default currency.
2. checking the locale of the browser and converting currency displays accordingly.
3. access to near real-time exchange rates.
4. other various assorted possible enhancements using the feature set of Finances::Quote.



---- Additional Comments From nengard@gmail.com 2010-02-17 13:11:43 ----

Is this related to http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3758 - where I ask to have exchange rates updated automatically?



---- Additional Comments From cnighswonger@foundations.edu 2010-02-17 13:19:25 ----

It is, only this is more extensive involving all currency code in Koha rather than just acquisitions.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:24 UTC  ---

This bug was previously known as _bug_ 4202 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4202

Actual time not defined. Setting to 0.0
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was chris.nighswonger@gmail.com.
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
Bug reassigned, setting status to "NEW".
   Previous status was "ASSIGNED".

Comment 1 Katrin Fischer 2016-06-19 22:08:43 UTC
Is this still valid? Should we split issues left into separate bugs from here?

1) The default currency is set via the Administraction > Currencies configuration.

3) Appears to be covered by bug 3758.

We also know have a TT plugin for formatting and a global system preference to determine which formatting to use.
Comment 2 Katrin Fischer 2019-05-04 13:44:07 UTC
(In reply to Chris Cormack from comment #0)

> This will allow:
> 1. the use of a single system preference to set the default currency.
> 2. checking the locale of the browser and converting currency displays
> accordingly.
> 3. access to near real-time exchange rates.
> 4. other various assorted possible enhancements using the feature set of
> Finances::Quote.

Closing this RESOLVED MOVED

1 has been fixed separately.

2 asks for using the local of the browser to convert currency display - this might not be desired. While you might offer different translations to your OPAC, displaying the currency the way it is used locally (where your library is situated) might make more sense.

3 Is a duplicate of bug 3758

4 is not clear on what kinds of 'assorted possible enhancements'.