Bug 4249 - Can't place multiple holds if one record has no holdable items (staff)
Summary: Can't place multiple holds if one record has no holdable items (staff)
Status: RESOLVED DUPLICATE of bug 7703
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: PC All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL: cgi-bin/koha/reserve/request.pl?bibli...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-23 05:15 UTC by Nicole C. Engard
Modified: 2016-08-19 19:13 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
One record without holdable items blocks all other holds. (20.86 KB, image/png)
2015-06-06 19:49 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:24:55 UTC


---- Reported by nengard@gmail.com 2010-02-23 17:15:25 ----

When placing a hold on multiple items in the staff client if one of the items can't have a hold placed on it then you can't place a hold on any of them.  You should be able to place a hold on the items that do allow holds without going back and choosing the items again.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:24 UTC  ---

This bug was previously known as _bug_ 4249 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4249

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Nicole C. Engard 2010-06-02 13:14:58 UTC
this is still an issue but can be overridden with the new preference to allow overiding of hold blocks ... but then it placed a hold on all of the items - even the ones where holds aren't allowed
Comment 2 Katrin Fischer 2015-06-06 19:49:05 UTC
Created attachment 39955 [details]
One record without holdable items blocks all other holds.

Still valid on current master.
Comment 3 Owen Leonard 2016-08-19 19:13:16 UTC

*** This bug has been marked as a duplicate of bug 7703 ***