Bug 4277 - budget planning refreshes funny
Summary: budget planning refreshes funny
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-26 04:29 UTC by Nicole C. Engard
Modified: 2015-12-03 22:02 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 4277: Display the correct budget planning after saving (1.13 KB, patch)
2015-03-24 15:25 UTC, Jonathan Druart
Details | Diff | Splinter Review
[Signed-off] Bug 4277: Display the correct budget planning after saving (1.31 KB, patch)
2015-03-24 16:13 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 4277: Display the correct budget planning after saving (1.36 KB, patch)
2015-03-24 20:37 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:25:17 UTC


---- Reported by nengard@gmail.com 2010-02-26 16:29:16 ----

after saving planning on a budget it refreshed the screen with another budget - not the one i was editing

URL Before: http://localhost:8080/cgi-bin/koha/admin/aqplan.pl?budget_period_id=3&authcat=MONTHS

After hitting save URL: http://localhost:8080/cgi-bin/koha/admin/aqplan.pl

Looks like it's loosing the budget id info.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:25 UTC  ---

This bug was previously known as _bug_ 4277 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4277

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Owen Leonard 2011-05-17 16:55:59 UTC
Confirmed this is still in master.
Comment 2 Marc Véron 2012-07-26 14:03:36 UTC
Confirmed, still same behaviour.
Comment 3 Pete Edwards 2014-10-17 13:37:48 UTC
Still apparent in 3.16.03.000
Comment 4 Jonathan Druart 2015-03-24 15:25:24 UTC Comment hidden (obsolete)
Comment 5 Marc Véron 2015-03-24 16:13:09 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-03-24 20:37:28 UTC
Created attachment 37198 [details] [review]
[PASSED QA] Bug 4277: Display the correct budget planning after saving

The budget_period_id is not pass to the script, so after saving the
budget planning, the planning for the first active budget is displayed.

Test plan:
1/ Edit a budget planning
2/ Save
3/ You should see the budget planning you were editing

Patch behaves as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Thx!
Comment 7 Tomás Cohen Arazi 2015-03-31 17:19:04 UTC
Patch pushed to master.

Thanks Joubu!
Comment 8 Chris Cormack 2015-04-06 08:55:30 UTC
Pushed to 3.18.x will be in 3.18.6