Bug 4283 - Merge bibliographic records
Summary: Merge bibliographic records
Status: RESOLVED DUPLICATE of bug 8064
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: PC All
: P5 - low enhancement with 10 votes (vote)
Assignee: Olli-Antti Kivilahti
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-26 05:03 UTC by Jane Wagner
Modified: 2022-08-22 05:41 UTC (History)
9 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Screen shot of initial bib merge feature setup (43.78 KB, image/jpeg)
2010-02-26 17:03 UTC, Chris Cormack
Details
Screen shot of search results (65.57 KB, image/jpeg)
2010-02-26 17:03 UTC, Chris Cormack
Details
Screen shot of combine screen (64.04 KB, image/jpeg)
2010-02-26 17:04 UTC, Chris Cormack
Details
Bug 4283 - Merge bibliographic records (12.35 KB, patch)
2014-11-28 16:08 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 4283 - Merge bibliographic records (22.35 KB, patch)
2014-12-01 12:19 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review
Bug 4283 - Merge bibliographic records. Followup. (9.54 KB, patch)
2014-12-18 09:15 UTC, Olli-Antti Kivilahti
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:25:21 UTC


---- Reported by jwagner@ptfs.com 2010-02-26 17:03:29 ----

Created an attachment
Screen shot of initial bib merge feature setup

Sponsored by East Brunswick Public Library, East Brunswick, NJ, USA and
Middletown Public Library, Middletown, NJ, USA.

Allows users to search for duplicate bib records by ISBN, LCCN, ISSN, Title, or Author.  You can either search for all duplicates (by using the checkbox) or a particular duplicate (by entering a search term with an * wildcard, like Rowling* or Harry Potter and*).  If results are found, the feature displays the MARC record for all possible duplicates.  A pulldown box lets the user select which record to keep (retaining that MARC data), combine (transfer items to the Keep title), or ignore (don't combine).  Note that the feature does not allow merging MARC fields from one title to another; it just transfers the items.



---- Additional Comments From jwagner@ptfs.com 2010-02-26 17:03:56 ----

Created an attachment
Screen shot of search results





---- Additional Comments From jwagner@ptfs.com 2010-02-26 17:04:28 ----

Created an attachment
Screen shot of combine screen





---- Additional Comments From paul.poulain@biblibre.com 2010-03-05 09:05:11 ----

jane : isn't this a duplicate of : http://git.koha.org/cgi-bin/gitweb.cgi?p=Koha;a=blob;f=cataloguing/merge.pl;h=63980168edfd886045638ecba40c032bfbdc110f;hb=HEAD ?



---- Additional Comments From jwagner@ptfs.com 2010-03-05 20:22:16 ----

Paul, I think we discussed this online.  You're referring to the merge function you've written, that is under the Lists function, correct?  Ours is a different approach and I think both can coexist.  We may need to see if they can be merged, or would need to be kept separate.




--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:25 UTC  ---

This bug was previously known as _bug_ 4283 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4283
Imported an attachment (id=1973)
Imported an attachment (id=1974)
Imported an attachment (id=1975)

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was kohaprogrammers@ptfs.com.
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
Bug reassigned, setting status to "NEW".
   Previous status was "ASSIGNED".
CC member jwagner@ptfs.com does not have an account here
The original submitter of attachment 1973 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1974 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1975 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Olli-Antti Kivilahti 2014-11-28 16:08:21 UTC Comment hidden (obsolete)
Comment 2 Jonathan Druart 2014-12-01 08:23:14 UTC
Olli,
Do you plan to worj on this?
If yes, please have a look at bug 8064 :)
Comment 3 Olli-Antti Kivilahti 2014-12-01 12:19:38 UTC
Created attachment 34032 [details] [review]
Bug 4283 - Merge bibliographic records

Adds a GUI for deduplicating regions of the biblionumber space in Koha. Deduplication happens using the given
C4::Matcher. Deduplicated biblionumber slice is limited with LIMIT- and OFFSET-clauses as well as a starting
biblionumber by C4::Biblio::GetBiblionumberSlice().

Deduplication search has the following defaults: Limit = 500, Offset = 0, Matcher = the lowest matcher_id in DB.

The speed of the deduplication process is mostly influenced by the complexity of the Matcher, but the GUI can
handle a limit of ~1000 relatively well with a Matcher using ~7 match points taking a couple of minutes.

From the deduplication GUI, merging is done with the lists-based cataloguing/merge.pl -tool.

-!-!-!-!-!-!-!-!-!-
-TEST PREPARATION:-
-!-!-!-!-!-!-!-!-!-

-2. Define/choose a Matcher from the admin/matching-rules.pl. For tutorial purposes use the default ISBN-based
    Matcher.
-1. Add two or more Bibliographic records, each having the same ISBN. Note the biblionumbers.
 0. Reindex the search index.

-!-!-!-!-!-!-
-TEST  PLAN:-
-!-!-!-!-!-!-

1. Go to cataloguing home (cataloguing/addbooks.pl) and observe a new toolbar item, "Deduplicator"! Go there!
2. In the deduplicator.pl, choose your Matcher and "Deduplicate!". This uses the default values.
2.a. If you don't get any results, enter the smaller biblionumber of the recently added duplicate ISBN Biblios'
     to the input field. Then retry submission. Use Limit of 2 for convenience.
3. Click the checkbox of a matched result to set it as the "merge target/reference", then click one or more
   matches to merge with the "merge target/reference", then click the "Merge!"-button on the boldfaced
   "match source"-row.
4. Merge using the merge.pl-tool as you normally would. As of writing that merge-feature supports only two
   Biblios, but Buug 8064 will bring support for merging multiple Biblios at once.

UNIT TESTS included for the C4::Biblio::GetBiblionumberSlice()
Comment 4 Olli-Antti Kivilahti 2014-12-18 09:15:28 UTC
Created attachment 34509 [details] [review]
Bug 4283 - Merge bibliographic records. Followup.
Comment 5 Marc Véron 2015-01-18 15:29:26 UTC
Does not apply.

Applying: Bug 4283 - Merge bibliographic records
Applying: Bug 4283 - Merge bibliographic records. Followup.
fatal: sha1 information is lacking or useless (Koha/Deduplicator.pm).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 4283 - Merge bibliographic records. Followup.
Comment 6 Jonathan Druart 2015-02-11 11:26:58 UTC
Olli, did you see my comment 2?
Comment 7 David Cook 2022-08-22 05:41:48 UTC
Unless someone can correct me, I'm marking this as duplicate of bug 8064 since we can merge bib records in Koha...

*** This bug has been marked as a duplicate of bug 8064 ***