Bug 4339 - catalog reports doesn't count a lot of items
Summary: catalog reports doesn't count a lot of items
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: unspecified
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Henri-Damien LAURENT
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-24 11:00 UTC by Nahuel Angelinetti
Modified: 2012-10-25 23:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:26:00 UTC


---- Reported by nahuel.angelinetti@biblibre.com 2010-03-24 11:00:49 ----

There is some leak in reports that doesn't count items that have no barcode.



---- Additional Comments From gmcharlt@gmail.com 2010-04-16 11:18:29 ----

Patch pushed.  Please test and close.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:26 UTC  ---

This bug was previously known as _bug_ 4339 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4339

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Owen Leonard 2010-07-07 18:15:03 UTC
Patch: http://lists.koha-community.org/pipermail/koha-patches/2010-March/011517.html

It would be good to know the steps to reproduce this problem since the report is so vague. Can anyone confirm whether this is now fixed?
Comment 2 Chris Cormack 2010-12-14 03:03:40 UTC
Want a challenge? Test me, I'm kinda vague and misunderstood, but you just might be the one person who can understand me.
Comment 3 Paul Poulain 2011-02-22 12:51:20 UTC
Owen, the interesting lines are :
-	$strsth .= "select distinctrow $linefield from biblioitems left join items on (items.biblioitemnumber = biblioitems.biblioitemnumber) where barcode $not LIKE ? AND $line is not null ";
+	my $strsth = "SELECT DISTINCTROW $linefield FROM biblioitems 
+	                INNER JOIN items USING (biblioitemnumber)
+	              WHERE $line IS NOT NULL ";

see the distinction between INNER JOIN and LEFT JOIN : http://www.w3schools.com/sql/sql_join_left.asp and http://www.w3schools.com/sql/sql_join_inner.asp

(the rest of the patch is just changing lc to UC for SQL terms)

it's in master though, so marking it resolved