Bug 4800 - Disable book cover image in the title view if the feature is on in the OPAC.
Summary: Disable book cover image in the title view if the feature is on in the OPAC.
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: rel_3_0
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Chris Cormack
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-21 01:43 UTC by infotech.sbc
Modified: 2014-12-07 20:03 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screenshots of the feature (238.25 KB, application/zip)
2010-05-21 01:43 UTC, infotech.sbc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description infotech.sbc 2010-05-21 01:43:29 UTC
Created attachment 2150 [details]
screenshots of the feature

There is a delay of approximately 5 seconds for the information of a book to display if the book cover image feature (google) is on. Responsiveness will be enhanced if the book cover will just be disabled in the title view since it is already seen in the search view. Attached pictures are example feature enhancement referring to the book "Oracle Database 11g".
Comment 1 Owen Leonard 2010-09-14 18:22:12 UTC
Please specify the browser, platform, and machine specs you're testing on. I've never seen any perceptible delay when using Google Jackets, but if the cause is a slow machine or slow browser I may be missing it.

I think not showing the book cover image in the detail view would be a mistake, but I'm open to investigating whether there is a bottleneck in the Google Jackets JavaScript.
Comment 2 infotech.sbc 2010-09-15 23:53:58 UTC
I'm using a PC with the following Specs:

AMD Athlon(tm) 64 X2 Dual
Core Processor 5000+
2.59 GHz, 896 MB of RAM
Physical Address Extension

host OS - Microsoft Windows XP Professional version 2002 Service Pack 3
guest OS - Ubuntu 10.04 server (x86)
Koha 3.0.6


I would like you to know that I am using a virtual machine (virtualbox)on top of Windows XP SP3. After some googling, I tried to enable the hardware virtualization of my pc in the BIOS and checked the "enable PAE" checkbox in the settings of Virtualbox. An increase in speed was significantly observable. Before doing that I also observed that only one CPU was used in processing (I opened the Task Manager of XP). Upon adjusting the settings of the PC and Virtualbox, the two processors worked. The overall performance of the system improved.
Comment 3 infotech.sbc 2010-09-15 23:55:05 UTC
(In reply to comment #1)
> Please specify the browser, platform, and machine specs you're testing on. I've
> never seen any perceptible delay when using Google Jackets, but if the cause is
> a slow machine or slow browser I may be missing it.
> 
> I think not showing the book cover image in the detail view would be a mistake,
> but I'm open to investigating whether there is a bottleneck in the Google
> Jackets JavaScript.

I'm using a PC with the following Specs:

AMD Athlon(tm) 64 X2 Dual
Core Processor 5000+
2.59 GHz, 896 MB of RAM
Physical Address Extension

host OS - Microsoft Windows XP Professional version 2002 Service Pack 3
guest OS - Ubuntu 10.04 server (x86)
Koha 3.0.6


I would like you to know that I am using a virtual machine (virtualbox)on top of Windows XP SP3. After some googling, I tried to enable the hardware virtualization of my pc in the BIOS and checked the "enable PAE" checkbox in the settings of Virtualbox. An increase in speed was significantly observable. Before doing that I also observed that only one CPU was used in processing (I opened the Task Manager of XP). Upon adjusting the settings of the PC and Virtualbox, the two processors worked. The overall performance of the system improved.
Comment 4 infotech.sbc 2010-09-15 23:58:47 UTC
(In reply to comment #1)
> Please specify the browser, platform, and machine specs you're testing on. I've
> never seen any perceptible delay when using Google Jackets, but if the cause is
> a slow machine or slow browser I may be missing it.
> 
> I think not showing the book cover image in the detail view would be a mistake,
> but I'm open to investigating whether there is a bottleneck in the Google
> Jackets JavaScript.

I'm using Opera 10.50 and firefox 3.60