Bug 4862 - "Browse by subject" is misnamed
Summary: "Browse by subject" is misnamed
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low minor with 5 votes (vote)
Target Milestone: ---
Assignee: Liz Rea
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 2204 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-09 03:27 UTC by Lars Wirzenius
Modified: 2014-05-26 21:04 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
bug 4862 - Change label of Browse by subject or author to Authority search (2.92 KB, patch)
2013-03-27 03:19 UTC, Liz Rea
Details | Diff | Splinter Review
bug 4862 - Change label of Browse by subject or author to Authority search (3.01 KB, patch)
2013-04-02 08:53 UTC, Mason James
Details | Diff | Splinter Review
bug 4862 - Change label of Browse by subject or author to Authority search (4.23 KB, patch)
2013-04-03 07:52 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wirzenius 2010-06-09 03:27:24 UTC
The OPAC interface has a search box, and underneath are two links: "Advanced Search" and "Browse by Subject". The latter one is, I feel, misnamed: it does not allow browsing in the normal sense. Instead, it is another kind of advanced search.

A proper browsing feature would allow you to click on lists of subjects, and get lists of books in those subjects. The current one requires you to know suitable search words, which you might not have at all.

In physical libraries (and bookstores), one of the most pleasurable things is to randomly walk and see what kinds of books there are, and what subjects there are, rather than look for a specific book. "Browse by subject" currently does not support that. It would be nice if it did. But that's a different thing.

However, in the meanwhile, it would be nice if the current "Browse by subject" could be renamed to, say, "Search by subject" or "Another kind of advanced search".
Comment 1 Nicole C. Engard 2010-06-09 11:52:24 UTC
*** Bug 2204 has been marked as a duplicate of this bug. ***
Comment 2 Owen Leonard 2010-06-09 13:09:58 UTC
The trouble with that search is that it searches a very specific thing: authority records. I think this functionality is only of interest to librarians or specialized subsets of library patrons like academic researchers or other who would have reason to know what authorities are. The good news is that this search can be hidden in the OPAC with the OpacAuthorities system preference.

I would frame the question this way: Given the fact that an authority search is only useful to someone with specialized knowledge, what is a logical label for that search? Is there a reason to even give it an "average patron friendly" label? Or should it just be labelled what it is: "Authority search?"
Comment 3 Elaine Bradtke 2011-02-07 16:53:40 UTC
Authority search is a reasonable name for it.
Comment 4 Elaine Bradtke 2011-02-13 10:42:52 UTC
(In reply to comment #3)
> Authority search is a reasonable name for it.

Meant to add that this feature would probably be more useful in the Staff interface, where the users actually know what authority records are.
Comment 5 Nicole C. Engard 2013-03-27 01:18:26 UTC
I agree - it's not a browse - it's a search and the label should say so.
Comment 6 Liz Rea 2013-03-27 03:19:33 UTC Comment hidden (obsolete)
Comment 7 Liz Rea 2013-03-27 03:22:57 UTC
doing this kind of goes against the push to de-librarianise the public interface... *however* I agree that the browse feature was mislabeled, and that this isn't a patron friendly feature in the first place. As Owen says, it should be a logical label for those people who use it, i.e. librarians. 

Since it can be hidden, I have no qualms about changing the name.
Comment 8 Nicole C. Engard 2013-03-27 12:37:21 UTC
Why not just change it to 'Subject search' that would make it work for the public and would be more accurate than 'Browse by subject'?  I agree that our patrons don't know what authorities are - I would however accept this patch over leaving it the way it is.

Nicole
Comment 9 Liz Rea 2013-03-27 19:54:12 UTC
Except an authority search is either subject or author, and "Subject or author search" is an awful lot of words to put there. Plus it's confusing to borrowers, because they can already do a subject or author search from the drop down menu, and it would be confusing to them to have two places, with the same name (more or less), searching different things.

At least, that's how I see it. :)
Comment 10 Elaine Bradtke 2013-03-27 21:36:06 UTC
I think the main objection I have is to the word 'browse' as it really isn't a browse feature.
We should try to describe it accurately. If we don't use librarian speak (Authorities) then we end up with longer phrases such as:
Search lists of names and subjects used in this catalog(ue)
or
Search controlled vocabulary  (!!)


Search authorities is brief and meaningful for the people who are most likely to use the feature.  For those who don't understand, I added an html help file that explains what it is, and how to use it should they choose to look into it.
Comment 11 Mason James 2013-04-02 08:53:19 UTC Comment hidden (obsolete)
Comment 12 Mason James 2013-04-02 08:55:33 UTC
(In reply to comment #11)
> Created attachment 17115 [details] [review] [review]
> bug 4862 - Change label of Browse by subject or author to Authority search
> 
> Signed-off-by: Mason James <mtj@kohaaloha.com>

works as stated - so signing-off...

thanks Liz
Comment 13 Jonathan Druart 2013-04-02 12:24:55 UTC
Liz, don't you think we should replace 2 strings in opac-authorities-home.tt too ("Browse by author or subject")?

I can do it in my signed-off patch if you agree.
Comment 14 Paul A 2013-04-02 16:08:04 UTC
Agreed not "browse." we resolved the semantics of this label a long time ago by using the phrase "Search by author or subject".

This patch appears to do what we did:

paul@hardy:/usr/share/koha$ sudo vi opac/htdocs/opac-tmpl/prog/en/includes/masthead.inc
/Browse by author or subject
[Edit 'Browse' ==> 'Search']
:x

BUT -- you also need:

paul@hardy:/usr/share/koha$ sudo vi opac/htdocs/opac-tmpl/prog/en/modules/opac-authorities-home.tt
/Browse by author or subject
[Edit 'Browse' ==> 'Search'
:x

otherwise the sub-header on the search page still reads "Browse..."

So, if the second part is included in the bug, it's OK to go (3.6.x and 3.8.x)
Comment 15 Liz Rea 2013-04-02 19:41:20 UTC
Yep, I'm happy to make those changes or someone else can in the sign off - no fuss to me either way.

:)
Comment 16 Jonathan Druart 2013-04-03 07:52:42 UTC
Created attachment 17157 [details] [review]
bug 4862 - Change label of Browse by subject or author to Authority search

Replicate:
Load the OPAC
You should see "Browse by Subject or Author right below the search box

To test:
Apply patch
Load the OPAC
You should see "Authority search" where "Browse by Subject or Author" was .

Signed-off-by: Mason James <mtj@kohaaloha.com>
Amended patch: change strings in opac-authorities-home.tt
Comment 17 Jared Camins-Esakov 2013-04-03 11:09:42 UTC
This patch has been pushed to master.
Comment 18 Chris Cormack 2013-04-24 22:12:46 UTC
Pushed to 3.10.x will be in 3.10.6