Bug 5125 - Cursor default location on circulation-home.pl
Summary: Cursor default location on circulation-home.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) trivial (vote)
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-12 14:46 UTC by Ian Walls
Modified: 2012-10-25 22:52 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
patch for bug 5125 (2.32 KB, patch)
2010-09-10 16:46 UTC, Ian Walls
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2010-08-12 14:46:22 UTC
When arriving at circulation-home.pl, the cursor is not automatically placed in the upper menu bar (which defaults to Check Out), as it does on /circ/circulation.pl or other pages.  This necessitates that the staff member clicks in the field to scan in a patron barcode, adding an extra step to the procedure.  Since this is the only search box on page, it makes sense to default here for a smoother workflow.

This behaviour was found on Firefox 3.5, and confirmed on Chrome.
Comment 1 Ian Walls 2010-09-10 16:46:45 UTC
Created attachment 2618 [details] [review]
patch for bug 5125

Fix was described by Owen Leonard over IRC chat
Comment 2 Chris Cormack 2010-12-14 07:12:10 UTC
Pushed, please test