Bug 5176 - SIPServer Incorrectly Requires Login over Socket
Summary: SIPServer Incorrectly Requires Login over Socket
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: SIP2 (show other bugs)
Version: rel_3_2
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Colin Campbell
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-25 19:43 UTC by Colin Campbell
Modified: 2015-12-03 22:00 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Campbell 2010-08-25 19:43:41 UTC
Comment in the source indicates a mis-reading of the standard. Assuming that over a raw socket connection login will be the first message. Standard states that whether login or another mechanism is used is optional. (It is configurable on 3M units and most others). (If used login should be first but it can be spoofed in our implementation anyway)
Use of login should be a configurable option. This may cause problems on flaky connections.
Comment 1 Marc Balmer 2012-03-22 11:52:08 UTC
The problem is that the SIP server actually needs an account on the ILS to perform it's operations.  So until a login message over the RAW is received, it can not do anything on the ILS.

See the patch I proposed for Bug 7787, it stays in a loop receiving messages (and or garbage) until it receives a login message.
Comment 2 Colin Campbell 2015-03-06 15:40:11 UTC
As its not causing anyone major problems and everyone seems happy with things the way they are lets consider this resolved