Bug 5201 - Patron last name dropped when record edited
Summary: Patron last name dropped when record edited
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: rel_3_2
Hardware: All Windows
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Frédéric Demians
QA Contact: Bugs List
URL:
Keywords:
: 5225 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-07 15:05 UTC by June Stancliff
Modified: 2012-10-25 22:52 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description June Stancliff 2010-09-07 15:05:55 UTC
When editing patron information, after saving the changes, sometimes the patron's last name disappears from the record. You then have to edit again, enter the last name, and re-save. The circulation staff has had this happen about a dozen times now.

June Stancliff
Comment 1 Owen Leonard 2010-09-07 15:48:30 UTC
I can't reproduce this error in the latest version. Can you give more details about when this happens? Are you editing the "whole" record, or are you clicking one of the "Edit" links on the patron details screen (members/moremember.pl?borrowernumber=XX) ? Does it always happen with certain patrons?
Comment 2 Greg 2010-09-07 17:32:40 UTC
http://www.screencast.com/t/ZTJmZWIz 

Turning on uppercasesurnames system preference causes the surname to disappear after creating a patron, followed by a "save", then an immediate edit of the patron data.

Turning off uppercasesurnames system preference causes the problem to disappear.

Greg
Comment 3 Greg 2010-09-07 17:49:37 UTC
Koha version: 	3.01.00.144
OS version ('uname -a'): 	Linux somename 2.6.26-2-686 #1 SMP Mon Jun 21 05:58:44 UTC 2010 i686 GNU/Linux
Perl interpreter: 	/usr/bin/perl
Perl version: 	5.010000
Perl @INC: 	/home/koha/kohaclone
/etc/perl
/usr/local/lib/perl/5.10.0
/usr/local/share/perl/5.10.0
/usr/lib/perl5
/usr/share/perl5
/usr/lib/perl/5.10
/usr/share/perl/5.10
/usr/local/lib/site_perl
.
MySQL version: 	mysql Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu (i486) using readline 5.2
Apache version: 	Server version: Apache/2.2.9 (Debian)
Zebra version: 	Zebra 2.0.44 (C) 1994-2010, Index Data ApS Zebra is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. SHA1 ID: 419ad759807269fdfa379799a051ed3a551c6541 Using ICU
Comment 4 Owen Leonard 2010-09-15 15:45:57 UTC
*** Bug 5225 has been marked as a duplicate of this bug. ***
Comment 6 Frédéric Demians 2010-09-15 16:00:07 UTC
> *** Bug 5225 has been marked as a duplicate of this bug. ***

Thanks Owen.
Comment 7 Frédéric Demians 2010-12-13 06:27:37 UTC
It's already in HEAD and 3.2.x branch. It doesn't need sign-off and should be closed.
Comment 8 Katrin Fischer 2010-12-13 09:39:04 UTC
Works in HEAD.