Bug 5202 - Merge authority records
Summary: Merge authority records
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low new feature with 10 votes (vote)
Target Milestone: ---
Assignee: Jared Camins-Esakov
QA Contact: Katrin Fischer
URL:
Whiteboard:
Keywords: rel_3_14_candidate
: 5271 5943 (view as bug list)
Depends on: 9755
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-07 17:42 UTC by Jared Camins
Modified: 2014-12-07 20:02 UTC (History)
9 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Large patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 5202: merge authorities from the authority file and reservoir (29.83 KB, patch)
2013-05-28 20:55 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: merge authorities from the authority file and reservoir (31.38 KB, patch)
2013-05-30 10:53 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: merge authorities from the authority file and reservoir (31.39 KB, patch)
2013-05-30 11:02 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: merge authorities from the authority file and reservoir (31.38 KB, patch)
2013-05-30 23:47 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: merge authorities from the authority file and reservoir (31.46 KB, patch)
2013-07-06 08:55 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 5202 QA follow-up: quiet warnings (2.59 KB, patch)
2013-07-14 21:15 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: merge authorities from the authority file and reservoir (31.42 KB, patch)
2013-07-23 22:13 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202 QA follow-up: quiet warnings (2.59 KB, patch)
2013-07-23 22:13 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: merge authorities from the authority file and reservoir (31.42 KB, patch)
2013-08-04 14:17 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202 QA follow-up: quiet warnings (2.53 KB, patch)
2013-08-04 14:17 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202 QA follow-up 2: fix overeager error message (3.14 KB, patch)
2013-08-04 14:17 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202: quiet warning (1.01 KB, patch)
2013-08-18 16:41 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202 QA follow-up: improve merge reference selection (3.46 KB, patch)
2013-08-18 17:02 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202 QA follow-up: improve merge reference selection (3.94 KB, patch)
2013-08-18 17:48 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5202 QA follow-up: correct license and POD errors (2.06 KB, patch)
2013-08-18 18:45 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
[PASSED QA] Bug 5202: merge authorities from the authority file and reservoir (31.52 KB, patch)
2013-08-18 18:50 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 5202 QA follow-up: quiet warnings (2.60 KB, patch)
2013-08-18 18:50 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 5202 QA follow-up 2: fix overeager error message (3.21 KB, patch)
2013-08-18 18:50 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 5202: Quiet warning (1.07 KB, patch)
2013-08-18 18:50 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 5202 QA follow-up: improve merge reference selection (4.04 KB, patch)
2013-08-18 18:51 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 5202 QA follow-up: correct license and POD errors (2.13 KB, patch)
2013-08-18 18:51 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins 2010-09-07 17:42:03 UTC
A feature that enables staff to merge authority records through the Staff client would be very helpful. Ideally I would like a "Merge?" checkbox next to each record in the Authority search results, and a "Merge" button somewhere which would ask which record to keep.
Comment 1 Elaine Bradtke 2011-02-13 10:39:36 UTC
*** Bug 5271 has been marked as a duplicate of this bug. ***
Comment 2 Nicole C. Engard 2013-02-05 01:40:37 UTC
This is still a desired feature (marking version to master instead of 3.4).
Comment 3 Jared Camins-Esakov 2013-05-28 20:55:00 UTC Comment hidden (obsolete)
Comment 4 Colin Campbell 2013-05-30 10:48:03 UTC
This is dependent on the patch associated with bug 9755
Comment 5 Jared Camins-Esakov 2013-05-30 10:53:53 UTC Comment hidden (obsolete)
Comment 6 Jared Camins-Esakov 2013-05-30 11:02:41 UTC Comment hidden (obsolete)
Comment 7 Jared Camins-Esakov 2013-05-30 23:47:09 UTC Comment hidden (obsolete)
Comment 8 Chris Cormack 2013-07-06 08:55:52 UTC Comment hidden (obsolete)
Comment 9 Jared Camins-Esakov 2013-07-14 21:15:58 UTC Comment hidden (obsolete)
Comment 10 Jared Camins-Esakov 2013-07-23 22:13:39 UTC Comment hidden (obsolete)
Comment 11 Jared Camins-Esakov 2013-07-23 22:13:49 UTC Comment hidden (obsolete)
Comment 12 Jared Camins-Esakov 2013-08-04 14:17:30 UTC Comment hidden (obsolete)
Comment 13 Jared Camins-Esakov 2013-08-04 14:17:36 UTC Comment hidden (obsolete)
Comment 14 Jared Camins-Esakov 2013-08-04 14:17:40 UTC Comment hidden (obsolete)
Comment 15 Jared Camins-Esakov 2013-08-18 16:41:54 UTC Comment hidden (obsolete)
Comment 16 Jared Camins-Esakov 2013-08-18 17:02:19 UTC Comment hidden (obsolete)
Comment 17 Jared Camins-Esakov 2013-08-18 17:48:56 UTC Comment hidden (obsolete)
Comment 18 Jared Camins-Esakov 2013-08-18 18:45:36 UTC Comment hidden (obsolete)
Comment 19 Katrin Fischer 2013-08-18 18:50:08 UTC
Created attachment 20444 [details] [review]
[PASSED QA] Bug 5202: merge authorities from the authority file and reservoir

This patch gives Koha the ability to merge authority records using the
same interface used by bibliographic records, though slightly different
methods for selecting which records to merge. The two ways to select
records are as follows:
1) Records can be selected from authority search results by clicking
   the "Merge" link for two records.
2) Authority records can be merged from the reservoir by clicking the
   merge-related links in the Manage staged MARC batch screen.

To test:
1) Apply patch.
2) Do a search for an authority record that will turn up multiple
   identical records (or at least two records that you don't mind
   merging).
3) Click the "Merge" link for the first record.
4) Click the "Merge" link for the second record.
5) Choose which fields from which record you want to appear in the
   resulting record.
6) Confirm that those are the fields that exist in the resulting record.
7) Stage an authority record (for example, an authority record you
   saved from your catalog.
8) Search for a record to merge with it using the "Search for a record
   to merge in a new window" link.
9) Merge these records, confirming that the resulting record (after
   going through the entire merging process) matches your expectations.
10) Set up a matching rule for authorities, and export an authority from
    your catalog that will match based on that rule. For MARC21, the
    following is a good choice for a rule:
    Matching rule code:  AUTHPER
    Description:         Personal name main entry
    Match threshold:     999
    Record type:         Authority record
    [Match point 1:]
    Search index:   mainmainentry
    Score:          1000
    Tag:            100
    Subfields:      a
11) Stage the record you just exported, choosing the matching rule you
    just created.
12) Merge the record using the "Merge" link, confirming that the
    resulting record (after going through the entire merging process)
    matches your expectations.
13) Sign off.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Testing notes on last patch in series.
Comment 20 Katrin Fischer 2013-08-18 18:50:39 UTC
Created attachment 20445 [details] [review]
[PASSED QA] Bug 5202 QA follow-up: quiet warnings

Due to massively incorrect data in the default authority frameworks,
we were getting warnings about undefined values and spaces from checking
which tab subfields/fields were displayed in. This patch eliminates those
warnings.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 21 Katrin Fischer 2013-08-18 18:50:49 UTC
Created attachment 20446 [details] [review]
[PASSED QA] Bug 5202 QA follow-up 2: fix overeager error message

When rebasing the patch for this, I accidentally moved the line
setting the mergereference when merging from breeding to *before*
I checked whether we were merging from breeding. Needless to say,
this caused problems. This patch fixes that, and:
* Makes the error translatable.
* Adds a missing authtypesloop argument for the template.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 22 Katrin Fischer 2013-08-18 18:50:58 UTC
Created attachment 20447 [details] [review]
[PASSED QA] Bug 5202: Quiet warning

$mergereference is not always defined, so we should check it is
defined before checking its value.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 23 Katrin Fischer 2013-08-18 18:51:34 UTC
Created attachment 20448 [details] [review]
[PASSED QA] Bug 5202 QA follow-up: improve merge reference selection

The link on the merge reference had been wrong, and framework types
were not indicated when you were merging records of two types. This
patch fixes those problems.

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes all tests and QA script.
Comment 24 Katrin Fischer 2013-08-18 18:51:45 UTC
Created attachment 20449 [details] [review]
[PASSED QA] Bug 5202 QA follow-up: correct license and POD errors

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 25 Galen Charlton 2013-10-10 22:01:13 UTC
Pushed to master.  Thanks, Jared!
Comment 26 Frédéric Demians 2013-11-27 08:05:09 UTC
It doesn't seem to work for UNIMARC. What happen to biblio records linked to deleted authority?
Comment 27 Martin Renvoize 2014-05-08 13:46:21 UTC
In 3.14.x
Comment 28 Martin Renvoize 2014-05-08 13:46:50 UTC
*** Bug 5943 has been marked as a duplicate of this bug. ***