Bug 5266 - Patron Search Produces Incorrectly Sorted and Missing Results
Summary: Patron Search Produces Incorrectly Sorted and Missing Results
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Kyle M Hall
QA Contact: Bugs List
URL:
Keywords:
: 5676 (view as bug list)
Depends on:
Blocks: 6253
  Show dependency treegraph
 
Reported: 2010-09-29 17:42 UTC by Greg
Modified: 2014-12-07 20:02 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2010-09-29 17:42:58 UTC
Koha version: 3.01.00.145
Zebra version: Zebra 2.0.44
MySQL version: mysql  Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu

Staff user reports that she types "johnston" (for example) into the patron search field on the staff interface.  This produces 10 pages of results, but not the desired patron named Jessica.  That name did not show up - it jumped from Jesse to Joan.  However, if the user went in and typed "johnston, jessica", it came up.

Also, later she had a different patron's record up and tried the search again with "johnston". That brought up the 10 pages of Johnstons again, but each page was alphabetical for the names displayed on that page - so each page started over with an "A" name and so on, but the names on each page were different and apparently non-repeating.
Comment 1 Nicole C. Engard 2011-01-04 14:34:53 UTC
I just wanted to bump this up a bit since it's still an issue.
Comment 2 Ian Walls 2011-04-20 14:59:21 UTC
*** Bug 5676 has been marked as a duplicate of this bug. ***