Bug 5490 - Is smsoverdues.pl an orphan
Summary: Is smsoverdues.pl an orphan
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Henri-Damien LAURENT
QA Contact: Mason James
URL:
Keywords:
: 8999 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-14 11:02 UTC by Colin Campbell
Modified: 2013-12-05 20:05 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 5490: smsoverdues.pl is an orphan (11.27 KB, patch)
2012-10-31 23:27 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 5490: smsoverdues.pl is an orphan (11.33 KB, patch)
2012-11-09 02:11 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Campbell 2010-12-14 11:02:01 UTC
In the course of checking something else I noticed that misc/cronjobs/smsoverdues.pl does not even compile due to a use of a non-existant module.

This suggests that noone is using this script. Either it should be removed or given some love and attention.
Comment 1 MJ Ray (software.coop) 2011-04-02 11:41:21 UTC
This bug is mentioned in:
Bug 5490: Update Lists and About Help Files	for 3.4 http://lists.koha-community.org/pipermail/koha-patches/2011-March/014228.html
Comment 2 Jared Camins-Esakov 2012-10-31 23:11:37 UTC
*** Bug 8999 has been marked as a duplicate of this bug. ***
Comment 3 Jared Camins-Esakov 2012-10-31 23:27:37 UTC Comment hidden (obsolete)
Comment 4 Chris Cormack 2012-11-09 02:11:21 UTC
Created attachment 13337 [details] [review]
Bug 5490: smsoverdues.pl is an orphan

The script misc/cronjobs/smsoverdues.pl requires HTML::Template::Pro and
uses templates that do not exist in Koha. Since this has been true for
at least a year and a half, and no one is aware of anyone who is using
it, it seems prudent to remove the script so that no one is confused
and/or distressed by its non-functioning nature.

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>
Comment 5 Mason James 2012-11-09 03:38:07 UTC
(In reply to comment #4)
> Created attachment 13337 [details] [review]
> Bug 5490: smsoverdues.pl is an orphan
> 
> The script misc/cronjobs/smsoverdues.pl requires HTML::Template::Pro and
> uses templates that do not exist in Koha. Since this has been true for
> at least a year and a half, and no one is aware of anyone who is using
> it, it seems prudent to remove the script so that no one is confused
> and/or distressed by its non-functioning nature.
> 
> Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

looks good, passing QA...
Comment 6 Jared Camins-Esakov 2012-11-10 02:45:22 UTC
This patch has been pushed to master.
Comment 7 Chris Cormack 2013-04-22 08:37:36 UTC
Released in 3.10.0