Bug 5539 - Add suggestion emails to messaging preferences
Summary: Add suggestion emails to messaging preferences
Status: NEW
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Bugs List
URL:
Keywords:
: 5352 (view as bug list)
Depends on:
Blocks: 1886
  Show dependency treegraph
 
Reported: 2010-12-23 15:46 UTC by Nicole C. Engard
Modified: 2019-03-16 11:15 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2010-12-23 15:46:56 UTC
Right now there are notices for suggestions, but no way for patrons to decide if they want those emails (or for the librarian to decide for that matter).  I think it just happens when a suggestion is submitted. 

I suggest that we add an option to the enhanced messaging options for the patron to decide if they get those emails.  Another suggestion is that the library have an on off toggle to decide if they're sent.  

Chat log below for more info.


[10:30]  <nengard> got a question about suggestion emails - are they being sent to anyone who submits a purchase suggestion?
[10:30]  <nengard> or is there supposed to be a preference or messaging option for patrons to decide if they get that email?
[10:31]  <Brooke> I think there might be two separate toggles.
[10:32]  <nengard> where might i find those? cause i'm not seeing them
[10:33]  <nengard> this is in reference to the commits of bug 4211, bug 5127 and bug 5126
[10:33]  <munin> Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=4211 major, P2, ---, chris, NEW, Acquisitions actions on suggestions don't generate email
[10:33]  <munin> Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5127 major, P5, ---, oleonard, RESOLVED FIXED, No sample suggestions notices are installed by default
[10:33]  <munin> Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5126 major, P5, ---, oleonard, NEW, Suggestions module missing from "add notice" form.
[10:34]  <owen> nengard: I don't know of a setting for that
[10:34]  <nengard> yeah - i'm not seeing one, so i'm assuming the system just sends the emails (now that it's fixed)
[10:34]  <nengard> I don't have emails on on my system to test with
[10:41]  <kf> nengard: I think you can perhaps deactivate it by deleting the notices templates?
[10:41]  <kf> have thought about it too - a system preference would be nice
[10:42]  <nengard> that's an idea
[10:43]  <nengard> kf i'd say it should be part of the enhanced messages - to let the patron decide if they want the emails or not
[10:44]  <kf> nengard: even better :)
[10:44]  <nengard> off to submit a enhancement :)
[10:44]  <kf> but perhaps an on /off for the feature would be good too
[10:44]  <kf> have both
[10:44]  <Brooke> *nod*
[10:44]  <kf> so library can decide if they want to offer the mails
[10:44]  <Brooke> I agree kf.
[10:44]  <kf> and let patron decide if he wants to get them
Comment 1 Owen Leonard 2014-04-25 18:34:14 UTC
*** Bug 5352 has been marked as a duplicate of this bug. ***