Bug 5784 - link to acq from budgets & funds
Summary: link to acq from budgets & funds
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL: /cgi-bin/koha/admin/aqbudgets.pl
Whiteboard:
Keywords: Academy
Depends on:
Blocks: 17972
  Show dependency treegraph
 
Reported: 2011-02-21 17:07 UTC by Nicole C. Engard
Modified: 2017-02-19 20:22 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 5784 - link to aq from budgets & funds (1.17 KB, patch)
2017-01-17 22:07 UTC, Gracie
Details | Diff | Splinter Review
Bug 5784 - link to aq from budgets & funds (1.23 KB, patch)
2017-01-18 07:34 UTC, Claire Gravely
Details | Diff | Splinter Review
Bug 5784 - link to aq from budgets & funds (1.29 KB, patch)
2017-01-19 12:05 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 5784 [QA Followup] - Move link to breadcrumbs (1.80 KB, patch)
2017-01-19 12:05 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 5784 - Undo link in breadcrumbs (1.07 KB, patch)
2017-02-17 12:10 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-02-21 17:07:06 UTC
When you're on the funds & budgets page it would be nice to have a link back to Acquisitions home. There are links to other Acq functions, just not to the home of the Acq module.
Comment 1 Gracie 2017-01-17 22:07:29 UTC
Created attachment 59113 [details] [review]
Bug 5784 - link to aq from budgets & funds

1. Go to /cgi-bin/koha/admin/aqbudgets.pl and notice that there is no link
to the aq home, there are other aq links but not back to the home
2. Apply the patch
3. Reload the page and notice there is link
Comment 2 Claire Gravely 2017-01-18 07:34:46 UTC
Created attachment 59143 [details] [review]
Bug 5784 - link to aq from budgets & funds

1. Go to /cgi-bin/koha/admin/aqbudgets.pl and notice that there is no link
to the aq home, there are other aq links but not back to the home
2. Apply the patch
3. Reload the page and notice there is link

Signed-off-by: Claire Gravely <claire_gravely@hotmail.com>
Comment 3 Kyle M Hall 2017-01-19 12:05:22 UTC
Created attachment 59234 [details] [review]
Bug 5784 - link to aq from budgets & funds

1. Go to /cgi-bin/koha/admin/aqbudgets.pl and notice that there is no link
to the aq home, there are other aq links but not back to the home
2. Apply the patch
3. Reload the page and notice there is link

Signed-off-by: Claire Gravely <claire_gravely@hotmail.com>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 4 Kyle M Hall 2017-01-19 12:05:29 UTC
Created attachment 59235 [details] [review]
Bug 5784 [QA Followup] - Move link to breadcrumbs

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 5 Kyle M Hall 2017-01-19 12:05:55 UTC
Pushed to master for 17.05, thanks Grace!
Comment 6 Katrin Fischer 2017-01-22 18:26:18 UTC
I am not sure about the follow-up -
+        <span><a href="/cgi-bin/koha/acqui/acqui-home.pl">Budgets administration</a></span>
I wouldn't expect "Budgets administration" to lead to the acquisition start page - but to the budgets page.
Comment 7 Katrin Fischer 2017-01-22 18:33:22 UTC
I think the follow-up is not correct.

- The last bit of the breadcrumb is the page you are on - so that should not be linked to the acquisition home page.
- It only appears on budgets, but not on funds, the original patch was in the include for all the pages. Also not on currencies.
Comment 8 Kyle M Hall 2017-01-23 11:01:03 UTC
(In reply to Katrin Fischer from comment #7)
> I think the follow-up is not correct.
> 
> - The last bit of the breadcrumb is the page you are on - so that should not
> be linked to the acquisition home page.
> - It only appears on budgets, but not on funds, the original patch was in
> the include for all the pages. Also not on currencies.

Agreed. The problem is that the budget and fund links are technically administration sections, where the rest are actually acquisitions. This make the breadcrumb linked more complicated than it should be ; )

Katrin, would you recommend I simply revert the followup, or do you have another recommendation?
Comment 9 Katrin Fischer 2017-01-23 11:44:06 UTC
Funds, budgets and currencies being in administration and not in acquisitions is a problem we run into every now and then - like with permissions or now the breadcrumbs. I have seen people get stuck there, so a link could indeed be helpful. I think the first patch would work for now, but we should fix capitalization in a follow-up :)

Maybe we could divide the side navigation into 'Administration' and 'Acquisitions' sections to make it a little easier to understand the differences?
Adding Owen in hope he has an idea.
Comment 10 Owen Leonard 2017-01-23 15:42:04 UTC
(In reply to Kyle M Hall from comment #8)

> Katrin, would you recommend I simply revert the followup, or do you have
> another recommendation?

I would revert the followup.

(In reply to Katrin Fischer from comment #9)
> I think the first patch would work for now,
> but we should fix capitalization in a follow-up :)

I agree.

 > Maybe we could divide the side navigation into 'Administration' and
> 'Acquisitions' sections to make it a little easier to understand the
> differences?

I'm going to submit a patch on a separate bug.
Comment 11 Katrin Fischer 2017-02-05 22:00:31 UTC
Do we still need to revert, or just the new patch from 17972?
Comment 12 Katrin Fischer 2017-02-07 06:38:13 UTC
Waiting for this to be resolved on master before pushing to 16.11.x
Comment 13 Kyle M Hall 2017-02-17 12:10:01 UTC
Issue resolved by 17972. Pushing followup to remove link from breadcrumbs.
Comment 14 Kyle M Hall 2017-02-17 12:10:41 UTC
Created attachment 60410 [details] [review]
Bug 5784 - Undo link in breadcrumbs

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 15 Katrin Fischer 2017-02-19 20:22:54 UTC
This won't get ported back to 16.11.x as it is an enhancement.