Bug 5901 - Make virtualshelves permissions more granular
Summary: Make virtualshelves permissions more granular
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Lists (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
: 2037 4253 (view as bug list)
Depends on:
Blocks: 7310
  Show dependency treegraph
 
Reported: 2011-03-19 22:15 UTC by Katrin Fischer
Modified: 2014-12-07 20:02 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-03-19 22:15:49 UTC
At the moment the virtualshelves system parameter is an ON/OFF option.

I think this needs to be more granular:
- no lists
- lists for staff only (= virtualshelves OFF now)
- allow patrons to create private lists
- allow patrons to create private and public lists (= virtuelshelves ON now)

Good or bad idea? Do we need more than that?
Comment 1 Jared Camins-Esakov 2011-03-22 12:32:06 UTC
Those sound like very reasonable permissions to me.
Comment 2 Ian Walls 2011-03-28 19:32:53 UTC
Should patrons be allowed to contribute to Open lists?  Or create them?
Comment 3 Katrin Fischer 2011-04-25 01:20:53 UTC
*** Bug 2037 has been marked as a duplicate of this bug. ***
Comment 4 Magnus Enger 2011-05-08 19:46:30 UTC
It might be useful to be able to let some patron categories create/edit lists and others not. I'm thinking of e.g. schools that might want to let all teachers create lists, but not the pupils.
Comment 5 Owen Leonard 2011-12-07 16:51:04 UTC
*** Bug 4253 has been marked as a duplicate of this bug. ***
Comment 6 Marcel de Rooy 2014-03-06 14:20:17 UTC
It looks like most of the issues mentioned on this report have been dealt with in the meantime.

If virtualshelves is off, opac users have no lists. Imo this pref could be an opac pref, why not allow staff users always to create lists? If the pref is off, a public list is only partially visible on staff side. I think we should just enable the functionality in staff "everywhere"; if you do not use it, no problem.

If virtualshelves is on, we can now control the creation of public lists by opac users with a specific pref. Patrons can create private lists. Sharing lists (bug 9032) is controlled by another pref. The permissions per list allow you to control adding items or not.

Comment4 of Magnus remains. Probably we could turn this into: Control the creation of public lists per user category instead of the generic pref. I would suggest to open a new report for that one, if it is really needed.

Comments welcome.
Comment 7 Katrin Fischer 2014-03-06 14:22:52 UTC
Hi Marcel,

I had started to work on this, lost my branch, got lost in the logic of the virtualshelves code and never got to return to it :( I think having a fresh start with a new bug describing exactly the now needed changes would be good.