Bug 5945 - can't search patron's email anymore
Summary: can't search patron's email anymore
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Ian Walls
QA Contact: Marcel de Rooy
URL:
Keywords:
: 6808 (view as bug list)
Depends on:
Blocks: 6253
  Show dependency treegraph
 
Reported: 2011-03-24 10:22 UTC by Nicole C. Engard
Modified: 2013-12-05 20:01 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (1.28 KB, patch)
2011-11-04 10:36 UTC, Ian Walls
Details | Diff | Splinter Review
signed off patch (1.36 KB, patch)
2011-11-05 10:20 UTC, Julian Maurice
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-03-24 10:22:55 UTC
Just last week (i think) we were talking about the email address for patron's being searchable. I tested it and documented it and today it is no longer searchable. Can we put that functionality back in?
Comment 1 Nicole C. Engard 2011-08-03 23:43:40 UTC
Had anyone had a chance to look at this - now we're pretty far away from this being functional so I don't know how easy it is to find. But when I reported this it had worked just a week or two before.

Nicole
Comment 2 Nicole C. Engard 2011-09-07 16:06:26 UTC
*** Bug 6808 has been marked as a duplicate of this bug. ***
Comment 3 Nicole C. Engard 2011-09-07 16:06:59 UTC
from another bug report:


Amit Gupta 2011-09-02 08:35:07 UTC

Nicole,
but the existing code is comment.

#($results)=Search(\@searchpatron,{surname=>1,firstname=>1},[$from,$to],undef,["firstname","surname","email","othernames"]
 ) if (@searchpatron);

So it is not possible to search by patron email id.
Comment 4 Ian Walls 2011-10-18 16:56:46 UTC
I will write the fix for this once bug 6253 is committed, as it will change the underlying landscape for this.  Should be a one-liner to add 'email' as a valid search field.
Comment 5 Ian Walls 2011-11-04 10:36:09 UTC Comment hidden (obsolete)
Comment 6 Julian Maurice 2011-11-05 10:20:28 UTC
Created attachment 6223 [details] [review]
signed off patch

Works as expected
Comment 7 Ian Walls 2011-11-05 10:58:11 UTC
Assigning to Marcel for QA.
Comment 8 Marcel de Rooy 2011-11-07 07:47:29 UTC
Small patch; passing QA.
Comment 9 Marcel de Rooy 2011-11-10 12:34:40 UTC
Has been pushed: commit c3abbedebedd34948b664a4d2a6b34dc4863802d !