Bug 6059 - Problem with changing quantity on uncertain prices list
Summary: Problem with changing quantity on uncertain prices list
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Jonathan Druart
QA Contact: Bugs List
URL: /cgi-bin/koha/acqui/uncertainprice.pl...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-05 12:10 UTC by Katrin Fischer
Modified: 2015-12-03 22:02 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 6059: Don't permit to change the quantity when items are created on ordering (2.39 KB, patch)
2015-04-08 08:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 6059: Don't permit to change the quantity when items are created on ordering (2.50 KB, patch)
2015-04-20 02:11 UTC, M. Tompsett
Details | Diff | Splinter Review
[PASSED QA] Bug 6059: Don't permit to change the quantity when items are created on ordering (2.57 KB, patch)
2015-04-20 06:00 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-04-05 12:10:21 UTC
On the list for managing uncertain prices there is a column for quantity that can be edited.

When creating your items on order the possibility to create items there does not make sense.

When changing the quantity the uncertain price will be unset and the quantity changes to your entered number. But no additional items will be created and there is no warning about that.
Comment 1 Owen Leonard 2013-03-26 16:47:54 UTC
This appears to still be valid in master as of 3.12 beta1.
Comment 2 Jonathan Druart 2015-03-25 15:06:35 UTC
Not sure to know what is the expected behavior here.
Comment 3 Katrin Fischer 2015-03-25 15:14:51 UTC
Hi Jonathan, I think it should not be possible to edit the quantity when items are created 'on order' - because it won't create the items.
Comment 4 Jonathan Druart 2015-04-08 08:09:38 UTC Comment hidden (obsolete)
Comment 5 M. Tompsett 2015-04-20 02:11:57 UTC Comment hidden (obsolete)
Comment 6 Katrin Fischer 2015-04-20 06:00:15 UTC
Created attachment 38153 [details] [review]
[PASSED QA] Bug 6059: Don't permit to change the quantity when items are created on ordering

If items are created on ordering, the quantity for uncertain prices
should not be editable.

Test plan:
0/ Set AcqCreateItem to "on ordering"
1/ Create a basket and add an order with 1+ items
2/ Mark it as uncertain prices
3/ Go on the uncertain prices page for this vendor
(acqui/uncertainprice.pl?booksellerid=X)
4/ Confirm you are not allowed to update the quantity
5/ Change the price and save
6/ Confirm the quantity is still correct

Set the pref to another value and confirm the behavior has not changed.

NOTE: Tested with 'on placing order' and 'on receiving order'.

Signed-off-by: Mark Tompsett <mtompset@hotmail.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Tomás Cohen Arazi 2015-04-30 19:35:13 UTC
Patch pushed to master.

Thanks Jonathan!
Comment 8 Chris Cormack 2015-05-17 04:38:48 UTC
Pushed to 3.18.x will be in 3.18.7