Bug 6085 - Can't Change language both in OPAC and staff client
Summary: Can't Change language both in OPAC and staff client
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) blocker (vote)
Assignee: Chris Cormack
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5917
  Show dependency treegraph
 
Reported: 2011-04-06 12:27 UTC by Pascale Nalon
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Patch to patch (802 bytes, patch)
2011-04-11 08:45 UTC, Colin Campbell
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Pascale Nalon 2011-04-06 12:27:56 UTC
In OPAC or in staff client clicing on a different language changes nothing.
It always stays in english.
Comment 1 Chris Cormack 2011-04-06 17:21:54 UTC
I would really appreciate people working on this, not being able to change language is a blocker.
Comment 2 Owen Leonard 2011-04-06 18:47:28 UTC
This seems to be related to Template Toolkit. I did not find the bug present in master. After switching to new/enh/bug_5917 I found that I could no longer switch languages.
Comment 3 Tomás Cohen Arazi 2011-04-06 19:31:01 UTC
I couldn't reproduce in 'new/enh/bug_5917' as I get auth.tt not found errors after tmpl_process3.pl created the es-ES translation.
Comment 4 Chris Cormack 2011-04-10 08:25:31 UTC
This should be fixed, in the 5917 branch now please test
Comment 5 Chris Cormack 2011-04-10 20:25:23 UTC
Language can now be changed, but there is a bug in the translator script
Comment 6 Chris Cormack 2011-04-11 03:59:05 UTC
Language can be changed, and the translation scripts.
Currently all utf8 problems have been fixed also.

Please test
Comment 7 Chris Cormack 2011-04-11 04:29:39 UTC
I will attempt to rework this with a filter tomorrow, but please test translations on master until then :)
Comment 8 Colin Campbell 2011-04-11 08:45:03 UTC
Created attachment 3858 [details] [review]
Patch to patch

Fix a typo causing it to generate an error
Comment 9 Chris Cormack 2011-04-11 08:49:07 UTC
Pushed follow up patch
Comment 10 Katrin Fischer 2011-04-24 10:36:36 UTC
Tested in OPAC and staff on master. Changing between languages works without problems for me.