Bug 6104 - Modifying an item causes it to lose its branch
Summary: Modifying an item causes it to lose its branch
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-07 08:33 UTC by Paul Poulain
Modified: 2019-06-27 09:24 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
proposed patch (1.05 KB, patch)
2011-04-07 08:34 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2011-04-07 08:33:26 UTC
Under certain circumstances, the item branch, when modified is lost.

Step to reproduce:
* IndependantBranches=OFF
* have 2 branches
* connect as a librarian in branch A
* try to modify an item from branch B
=> the form now select branch A for the item
Comment 1 Paul Poulain 2011-04-07 08:34:56 UTC
Created attachment 3768 [details] [review]
proposed patch
Comment 2 Sophie MEYNIEUX 2011-04-07 09:24:08 UTC
I have tried to modify a item before applying the patch. Homebranch and holdingbranch are set to my branch whatever value they had before.

I have applied the patch and tried to modify an item. Homebranch and holding branch keep their previous value.
Comment 3 Chris Cormack 2011-04-07 22:30:48 UTC
Patch has not hit the mailing list yet, can it be attached to the bug.
Comment 4 Chris Cormack 2011-04-11 21:53:37 UTC
This still needs the signed off patch, I really would like to push this, but no signed off patch attached here, or on the mailing list
Comment 5 Chris Cormack 2011-04-14 06:31:17 UTC
Patch finally came through on the mailing list (i suspect it got held up for moderation) pushed now
Comment 6 Katrin Fischer 2011-04-24 12:00:11 UTC
Successfully tested on 3.4.