Bug 6152 - Authority-zebra-indexdefs.xsl should indicate it's automatically generated
Summary: Authority-zebra-indexdefs.xsl should indicate it's automatically generated
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: unspecified
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Jared Camins-Esakov
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-09 15:29 UTC by Jared Camins-Esakov
Modified: 2012-10-25 23:09 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
proposed patch (3.91 KB, patch)
2011-04-12 12:16 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2011-04-09 15:29:30 UTC
At present there is no indication in the source tree that etc/zebradb/marc_defs/marc21/authorities/authority-zebra-indexdefs.xsl should be automatically generated from the authority-koha-indexdefs.xml file. There probably should be, so that developers know not to edit that file by hand (and know what authority-koha-indexdefs.xml is for).
Comment 1 Jared Camins-Esakov 2011-04-12 12:16:22 UTC
Created attachment 3894 [details] [review]
proposed patch
Comment 2 Ian Walls 2011-05-13 14:08:51 UTC
This patch can be confirmed by reading the code.  Since there is no authority-zebra-indexdefs.xsl for UNIMARC, I'm marking this as Passed QA.
Comment 3 Chris Cormack 2011-05-14 07:14:24 UTC
Pushed and merge to master
Comment 4 Jared Camins-Esakov 2011-07-08 14:39:47 UTC
Seems to be working now. Closing.