Bug 6158 - Permissions scoped wrong after change to T::T
Summary: Permissions scoped wrong after change to T::T
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Jared Camins-Esakov
QA Contact: Bugs List
URL:
Keywords:
: 6157 (view as bug list)
Depends on:
Blocks: 5917 6157
  Show dependency treegraph
 
Reported: 2011-04-11 15:40 UTC by Jared Camins-Esakov
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Signed-off patch (17.56 KB, patch)
2011-04-11 16:18 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Camins-Esakov 2011-04-11 15:40:30 UTC
The automatic translation from HTML Template Pro to Template::Toolkit incorrectly scoped permission checks within loops.
Comment 1 Owen Leonard 2011-04-11 16:18:54 UTC
Created attachment 3872 [details] [review]
Signed-off patch
Comment 2 Chris Cormack 2011-04-11 21:15:54 UTC
*** Bug 6157 has been marked as a duplicate of this bug. ***
Comment 3 Chris Cormack 2011-04-11 21:17:31 UTC
Pushed please test
Comment 4 Jared Camins-Esakov 2011-07-08 14:41:12 UTC
Seems to be working now. Closing.