Bug 6258 - Guided reports wizard 'Build new' brings up empty page
Summary: Guided reports wizard 'Build new' brings up empty page
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Reports (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Liz Rea
QA Contact: Bugs List
URL: /cgi-bin/koha/reports/guided_reports....
Keywords:
: 6307 (view as bug list)
Depends on:
Blocks: 5917
  Show dependency treegraph
 
Reported: 2011-04-24 15:53 UTC by Katrin Fischer
Modified: 2012-10-25 23:03 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (1.13 KB, patch)
2011-05-20 20:11 UTC, Liz Rea
Details | Diff | Splinter Review
Followup - removes the commented out old bad code (975 bytes, patch)
2011-05-20 20:14 UTC, Liz Rea
Details | Diff | Splinter Review
Signed-off patch (1.11 KB, patch)
2011-05-23 13:29 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-04-24 15:53:42 UTC
Trying to 'Build new' report using Guided Reports Wizard opens empty page.
Comment 1 Owen Leonard 2011-05-05 12:15:24 UTC
*** Bug 6307 has been marked as a duplicate of this bug. ***
Comment 2 Nicole C. Engard 2011-05-13 17:18:12 UTC
I'm thinking that this is a tt issue, do we have any other way to get to this page at this time?

Nicole
Comment 3 Liz Rea 2011-05-20 20:11:12 UTC Comment hidden (obsolete)
Comment 4 Liz Rea 2011-05-20 20:14:41 UTC Comment hidden (obsolete)
Comment 5 Magnus Enger 2011-05-21 12:34:08 UTC
Sorry, the patch does not apply for me: 

git am -i3u bug6258.patch

Applying: Bug 6258 Followup - Removing the bad code that I accidentally left in.
fatal: sha1 information is lacking or useless (reports/guided_reports.pl).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 6258 Followup - Removing the bad code that I accidentally left in.
Comment 6 Magnus Enger 2011-05-21 12:42:35 UTC
PS. The first patch, with the commented line left in, applies nicely and works as advertised...
Comment 7 Owen Leonard 2011-05-23 13:25:07 UTC
Looks like the two patches just need to be squashed.
Comment 8 Owen Leonard 2011-05-23 13:29:34 UTC
Created attachment 4232 [details] [review]
Signed-off patch

Squashed the two patches and signed off.
Comment 9 Ian Walls 2011-05-25 21:00:46 UTC
Tested, confirmed, works.  Marking as Passed QA.
Comment 10 Chris Cormack 2011-05-25 23:29:51 UTC
Pushed, please test and mark resolved
Comment 11 Magnus Enger 2011-05-26 07:07:49 UTC
Reports > Build new displays as expected, I'm marking this fixed. 

However, it looks like some of the options in step 5 and 6 are not displaying properly. I'll investigate some more and create a new bug report if it's needed.
Comment 12 Owen Leonard 2011-05-27 14:45:05 UTC
The problem with steps 5 and 6 is now Bug 6417 and I have submitted a patch.