Bug 6291 - Cart printing truncated in Firefox
Summary: Cart printing truncated in Firefox
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Browser compatibility (show other bugs)
Version: 3.6
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
: 7199 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-02 19:27 UTC by Owen Leonard
Modified: 2014-05-26 21:04 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (1.45 KB, patch)
2011-05-02 19:42 UTC, Owen Leonard
Details | Diff | Splinter Review
Revised fix (2.41 KB, patch)
2011-06-06 12:48 UTC, Owen Leonard
Details | Diff | Splinter Review
proposed patch (passed QA) (2.41 KB, patch)
2011-08-10 15:16 UTC, Paul Poulain
Details | Diff | Splinter Review
Alternate fix (1.10 KB, patch)
2011-12-06 18:00 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-05-02 19:27:16 UTC
If you have several pages of items in your cart and you try to print it in Firefox your printout will only include the first few pages. This issue is probably not unique to the cart, but to any print view which includes a large, multi-page table.
Comment 1 Owen Leonard 2011-05-02 19:42:34 UTC Comment hidden (obsolete)
Comment 2 Frédéric Demians 2011-05-13 06:47:39 UTC
I can reproduce this bug in Firefox 3.5. But it doens't exist anymore on
Firefox 4.0 (version Mac). I've tested this patch with FF 3.5. I doesn't
solve the bug.
Comment 3 Owen Leonard 2011-06-06 12:48:07 UTC Comment hidden (obsolete)
Comment 4 Nicole C. Engard 2011-07-06 16:14:08 UTC
Tested in FF5 on Mac and it was still a bug and the patch fixed it! Signed off.
Comment 5 Paul Poulain 2011-08-10 15:16:05 UTC Comment hidden (obsolete)
Comment 6 Chris Cormack 2011-08-11 01:36:57 UTC
Pushed, fixed missing sign off also (Paul you missed your one too, must be something about this bug)
Comment 7 Owen Leonard 2011-11-30 13:25:19 UTC
I think my fix for this bug should be reverted. It's causing problems like Bug 7279 and font-sizing problems in receipts.
Comment 8 Paul Poulain 2011-11-30 14:05:25 UTC
well... i'm not sure the 6291 should be reverted, unless, owen, you know how to write a better fix.
The 6291 fix solves a major problem (you don't get pages 2+, while bug 7279 is minor (the info is displayed, poorly, but it's here)

Note that if everybody think I should revert i'll do it.
Comment 9 Ian Walls 2011-11-30 15:17:32 UTC
I'm inclined to agree with Owen.  This fix has caused numerous problems for our partners.  It changes both print.css files, which is used on all the following files:

INTRANET:
includes/help-top.inc
includes/doc-head-close-receipt.inc
includes/doc-head-close.inc
catalogue/detailprint.tt
basket/basket.tt
members/moremember-receipt.tt
members/moremember-print.tt

OPAC:
includes/doc-head-close.inc
opac-basket.tt

It changes the font definition in <body>, and the widths/heights on very high-level HTML fields (not just for specific classes or IDs).  This has bled through into lots of related problems.

Better to revert, and find a better alternate solution.
Comment 10 Owen Leonard 2011-12-06 18:00:32 UTC
Created attachment 6609 [details] [review]
Alternate fix

Here's a less-drastic solution that works in my tests under Firefox 3.6 and 8 on Windows 7.
Comment 11 Paul Poulain 2011-12-07 15:11:23 UTC
As:
* this problem is very annoying
* has a trivial fix that i've checked

I've pushed the updated fix without waiting for another signature

Patch pushed, please test

(it's really a crazy FF bug !!!)
Comment 12 Owen Leonard 2012-05-22 18:09:45 UTC
*** Bug 7199 has been marked as a duplicate of this bug. ***
Comment 13 Jared Camins-Esakov 2012-05-24 01:04:46 UTC
This patch was incorporated into 3.6.x prior to 3.6.4.