Bug 6508 - Show indication of existing 'Charges' on tab of the same name
Summary: Show indication of existing 'Charges' on tab of the same name
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Fines and fees (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Martin Renvoize
QA Contact: Bugs List
URL:
Keywords:
: 13652 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-15 19:09 UTC by Helen Linda
Modified: 2020-05-18 14:31 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
With this enhancement the amount of pending charges/credits will be shown in the tab description on the checkouts and details pages of a patron account in the staff interface. When there are no pending charges, the tab won't be visible.
Version(s) released in:
20.05.00


Attachments
Screenshot of Patron Details Tabs in Staff Client (22.18 KB, image/png)
2011-06-15 19:09 UTC, Helen Linda
Details
Bug 6508: Add balance to `Fines & Charges` tab (1.13 KB, patch)
2019-10-23 10:38 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 6508: Add balance to `Fines & Charges` tab (1.18 KB, patch)
2020-02-13 04:28 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 6508: (follow-up) Change layout of price and hide tab if no fines (2.00 KB, patch)
2020-02-13 04:29 UTC, Aleisha Amohia
Details | Diff | Splinter Review
Bug 6508: Add balance to `Fines & Charges` tab (1.24 KB, patch)
2020-02-13 11:07 UTC, David Nind
Details | Diff | Splinter Review
Bug 6508: (follow-up) Change layout of price and hide tab if no fines (2.06 KB, patch)
2020-02-13 11:07 UTC, David Nind
Details | Diff | Splinter Review
Bug 6508: Add balance to `Fines & Charges` tab (1.24 KB, patch)
2020-02-14 16:27 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6508: (follow-up) Change layout of price and hide tab if no fines (2.06 KB, patch)
2020-02-14 16:27 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6508: (follow-up) Remove dependency on jquery for check in templates (3.32 KB, patch)
2020-02-14 16:27 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 6508: Add balance to `Fines & Charges` tab (1.24 KB, patch)
2020-02-14 18:31 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 6508: (follow-up) Change layout of price and hide tab if no fines (2.06 KB, patch)
2020-02-14 18:31 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 6508: (follow-up) Remove dependency on jquery for check in templates (3.38 KB, patch)
2020-02-14 18:31 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Helen Linda 2011-06-15 19:09:57 UTC
Created attachment 4487 [details]
Screenshot of Patron Details Tabs in Staff Client

On the patron details page in the staff client,if a patron has something checked out or on hold, it shows how many items in the check out or hold tab at the bottom of the page. It does not, however, show any indication of an amount of fines or charges unless you click on it. Please refer to the attached screenshot.

Proposals for fix:

1.  Have the "total due" or the number of fines that have been assessed show in the tab before the words "Fines and charges", just as a number shows before checkouts and holds? 

2.  Make the tab to be "hot" in some way, like if a patron owes fines, the font changes to bold red for that tab?
Comment 1 j.kylmala 2015-08-25 14:41:10 UTC
In the checkout page there is for example the message:

Attention:
     Fees & Charges: Patron has Outstanding fees & charges of 2.00. <Make payment>

This message can vary if there is some other information which might prevent the checkout.

I propose that we include that same thing to the page Details (maybe under the alternate address info). I looked into this already but it looked difficult to implement because at the moment there is no abstraction in the code which serves the Check out page. And the solution which I see as doable in a short period of time (4 hours) is to just copy paste the code from circulation.pl. Otherwise it could take day(s) to refactor circulation.pl to use some generic functions to get the info. And then after that do the code which shows the info in the Details page... Refactoring is what I would go with but... We will see.

I like also the idea of having the red indication in the fines tab and it could also have the amount owed in the title.
Comment 2 j.kylmala 2015-09-02 08:21:54 UTC
Please, see also the bug 3153. Maybe we could refactor the code so that we could  have the alert

Attention:
     Fees & Charges: Patron has Outstanding fees & charges of 2.00. <Make payment>

in many places shown easily.
Comment 3 Indranil Das Gupta 2018-06-06 23:10:15 UTC
*** Bug 13652 has been marked as a duplicate of this bug. ***
Comment 4 Katrin Fischer 2019-03-16 10:04:06 UTC
I really like Hene's idea of having the amount on the tab or at least some sign of existing fines as that would match the other tabs.
Comment 5 Brian 2019-04-24 00:46:06 UTC
Any Updates on bug 6508

Carnegie team
Comment 6 Martin Renvoize 2019-10-23 10:38:39 UTC
Created attachment 94601 [details] [review]
Bug 6508: Add balance to `Fines & Charges` tab
Comment 7 Martin Renvoize 2019-10-23 10:40:08 UTC
Well.. this patch adds the detail into the tab as requested.. however I'm really not sure what the point of that tab is at all now.. all it displays when clicked is this exact information.. did it show a table of charges in there at some point perhaps?
Comment 8 Katrin Fischer 2019-11-24 13:08:15 UTC
I agree with Martin that this doesn't add any additional information. 

I have another suggestion: We could only show the tab when there are any fines and charges.

This way, for libraries not using fines it will be a nicer display and the tab appearing will have a meaning.

I've also noticed that we only show the tab on details, but not on the checkouts tab.
Comment 9 Séverine Queune 2019-11-26 11:08:30 UTC
(In reply to Katrin Fischer from comment #8)
> I agree with Martin that this doesn't add any additional information. 
> 
Does this tab really needs to be kept ?
As Katrin said, it the only page where it's display, and we have and alert at the top of the page showing the total amount of charges, with 2 useful action buttons.
Isn't that enough ?

> I have another suggestion: We could only show the tab when there are any
> fines and charges.
> This way, for libraries not using fines it will be a nicer display and the
> tab appearing will have a meaning.
> 
+1 if the tab is kept !
Comment 10 Martin Renvoize 2019-11-26 12:43:45 UTC
+1 to just getting rid of it.
Comment 11 Aleisha Amohia 2020-02-13 04:28:56 UTC
Created attachment 98786 [details] [review]
Bug 6508: Add balance to `Fines & Charges` tab

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>
Comment 12 Aleisha Amohia 2020-02-13 04:29:03 UTC
Created attachment 98787 [details] [review]
Bug 6508: (follow-up) Change layout of price and hide tab if no fines

With this patch, the tab will not show if there are no fines.
I've also changed how the fines look in the tab header to look more like
the OPAC fines tab.
Comment 13 David Nind 2020-02-13 11:07:09 UTC
Created attachment 98809 [details] [review]
Bug 6508: Add balance to `Fines & Charges` tab

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>

Signed-off-by: David Nind <david@davidnind.com>
Comment 14 David Nind 2020-02-13 11:07:13 UTC
Created attachment 98810 [details] [review]
Bug 6508: (follow-up) Change layout of price and hide tab if no fines

With this patch, the tab will not show if there are no fines.
I've also changed how the fines look in the tab header to look more like
the OPAC fines tab.

Signed-off-by: David Nind <david@davidnind.com>
Comment 15 Katrin Fischer 2020-02-14 16:27:46 UTC
Created attachment 98972 [details] [review]
Bug 6508: Add balance to `Fines & Charges` tab

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>

Signed-off-by: David Nind <david@davidnind.com>
Comment 16 Katrin Fischer 2020-02-14 16:27:50 UTC
Created attachment 98973 [details] [review]
Bug 6508: (follow-up) Change layout of price and hide tab if no fines

With this patch, the tab will not show if there are no fines.
I've also changed how the fines look in the tab header to look more like
the OPAC fines tab.

Signed-off-by: David Nind <david@davidnind.com>
Comment 17 Katrin Fischer 2020-02-14 16:27:54 UTC
Created attachment 98974 [details] [review]
Bug 6508: (follow-up) Remove dependency on jquery for check in templates

Should work as before with the test plan from the second patch. But
removes the added jQuery display control code in favor of checking
if fines is set on template level.

For several patrons with and without fines and with credits:
- Check the Fines & Charges only display when there is something to see
Comment 18 Katrin Fischer 2020-02-14 16:28:49 UTC
I am not in favor of relying on JavaScript here - so I am proposing a follow-up that uses checks on TT level instead. Could you have a look Aleisha or David?
Comment 19 Owen Leonard 2020-02-14 18:31:42 UTC
Created attachment 99004 [details] [review]
Bug 6508: Add balance to `Fines & Charges` tab

Signed-off-by: Aleisha Amohia <aleishaamohia@hotmail.com>

Signed-off-by: David Nind <david@davidnind.com>
Comment 20 Owen Leonard 2020-02-14 18:31:45 UTC
Created attachment 99005 [details] [review]
Bug 6508: (follow-up) Change layout of price and hide tab if no fines

With this patch, the tab will not show if there are no fines.
I've also changed how the fines look in the tab header to look more like
the OPAC fines tab.

Signed-off-by: David Nind <david@davidnind.com>
Comment 21 Owen Leonard 2020-02-14 18:31:48 UTC
Created attachment 99006 [details] [review]
Bug 6508: (follow-up) Remove dependency on jquery for check in templates

Should work as before with the test plan from the second patch. But
removes the added jQuery display control code in favor of checking
if fines is set on template level.

For several patrons with and without fines and with credits:
- Check the Fines & Charges only display when there is something to see

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 22 Aleisha Amohia 2020-02-16 20:18:48 UTC
(In reply to Katrin Fischer from comment #18)
> I am not in favor of relying on JavaScript here - so I am proposing a
> follow-up that uses checks on TT level instead. Could you have a look
> Aleisha or David?

Looks good Katrin
Comment 23 Martin Renvoize 2020-02-19 16:12:49 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 24 Joy Nelson 2020-03-13 00:43:06 UTC
enhancement not backported to 19.11.x
Comment 25 vimal kumar 2020-05-16 18:36:16 UTC
Thank you all.